Error code 2 no such file or directory for table. Dada2 denoise

Hello so I have been having issues running Dada2 on my data.
I keep getting this error stating that there is no such file or directory pointing to the table that I thought was supposed to be generated by this command.

I found another post where someone had the same issue (below), but it had been closed.
I tried to follow the solution proposed in the reply (making another place for the temp files and directing them there), but that gave me the same error.
I have also increased the amount of space (MB) allotted to the machine.

Is there a way I can fix this?

Thank you,
Megan

$ qiime dada2 denoise-single --i-demultiplexed-seqs /home/qiime2/Desktop/18S/1-41/demux_1-41.qza --p-trim-left 18 --p-trunc-len 0 --o-representative-sequences /home/qiime2/Desktop/18S/1-41/dada2/dada2_rep_seqs.qza --o-table /home/qiime2/Desktop/18S/1-41/dada2/dada2_table.qza

Traceback (most recent call last):
File “/home/qiime2/miniconda/envs/qiime2-2017.12/bin/qiime”, line 11, in
sys.exit(qiime())
File “/home/qiime2/miniconda/envs/qiime2-2017.12/lib/python3.5/site-packages/click/core.py”, line 722, in call
return self.main(*args, **kwargs)
File “/home/qiime2/miniconda/envs/qiime2-2017.12/lib/python3.5/site-packages/click/core.py”, line 697, in main
rv = self.invoke(ctx)
File “/home/qiime2/miniconda/envs/qiime2-2017.12/lib/python3.5/site-packages/click/core.py”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/qiime2/miniconda/envs/qiime2-2017.12/lib/python3.5/site-packages/click/core.py”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/home/qiime2/miniconda/envs/qiime2-2017.12/lib/python3.5/site-packages/click/core.py”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/home/qiime2/miniconda/envs/qiime2-2017.12/lib/python3.5/site-packages/click/core.py”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/qiime2/miniconda/envs/qiime2-2017.12/lib/python3.5/site-packages/q2cli/commands.py”, line 237, in call
path = result.save(output)
File “/home/qiime2/miniconda/envs/qiime2-2017.12/lib/python3.5/site-packages/qiime2/sdk/result.py”, line 143, in save
self._archiver.save(filepath)
File “/home/qiime2/miniconda/envs/qiime2-2017.12/lib/python3.5/site-packages/qiime2/core/archive/archiver.py”, line 341, in save
self.CURRENT_ARCHIVE.save(self.path, filepath)
File “/home/qiime2/miniconda/envs/qiime2-2017.12/lib/python3.5/site-packages/qiime2/core/archive/archiver.py”, line 161, in save
allowZip64=True) as zf:
File “/home/qiime2/miniconda/envs/qiime2-2017.12/lib/python3.5/zipfile.py”, line 1009, in init
self.fp = io.open(file, filemode)
FileNotFoundError: [Errno 2] No such file or directory: ‘/home/qiime2/Desktop/Megan_18S/1-41/dada2/dada2_table.qza’

Hi @megladds! How long is this running for before that error message pops up? The thread you linked to above has to do with a bug on macOS, where jobs running longer than about 3 days break down because the operating system cleans up the temporary files before we are done working with them! If this failure is happening in under 3 days, that seems to indicate that something else is afoot!

Does this directory actually exist, /home/qiime2/Desktop/Megan_18S/1-41/dada2? QIIME 2 won’t make that directory for you, so if it doesn’t exist, that would explain the error you are seeing. To fix it, go ahead and create that directory using something like mkdir -p /home/qiime2/Desktop/Megan_18S/1-41/dada2, or using the file explorer GUI native to the operating system. Hope that helps, and keep us posted! :t_rex:

I had made the dada2 directory by just creating the folder.
I deleted it, used the mkdir command to create the folder and it worked…thanks :slight_smile:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.