dlopen cannot load any more object with static TLS

I''ve installed qiime2 2022.8 via conda
However, I encountered error when I try to activate qiime 2022.8.
The error msg are...
" import sklearn.metrics
File "/home/ccadmin/miniconda3/envs/qiime2-2022.8/lib/python3.8/site-packages/sklearn/init.py", line 83, in
from .utils._show_versions import show_versions
File "/home/ccadmin/miniconda3/envs/qiime2-2022.8/lib/python3.8/site-packages/sklearn/utils/_show_versions.py", line 12, in
from ._openmp_helpers import _openmp_parallelism_enabled
ImportError: dlopen: cannot load any more object with static TLS"

I am not familiar with conda or python and is there anyway to solve the error?

Hello @Rich, I am unfortunately unable to reproduce this error. To clarify, you installed QIIME 2 2022.8 via conda using the instructions found here correct? Now when you run conda activate qiime2-2022.8 you're getting that error? What kind of OS and environment are you installing QIIME 2 on?

Thank you @Oddant1.
I run conda activate qiime2-2022.8 and got the error. Because the conda env prompt appeared, I tried to run denoise and the same msg appeared.

I installed QIIME 2022.8 and 2022.3 via conda by the instructions in https://docs.qiime2.org and both 2022.3 & 2022.8 encountered the same issue. I have no such problem when I used QIIME2 earlier versions.
I have uninstalled conda and installed the Miniconda3-py39_4.12.0-Linux-x86_64. However, same issue persisted.

Can you try removing your qiime2-2022.8 environment and then, while in your base conda environment, running the command conda update conda then can you run the command conda clean --all then try to recreate your qiime2-2022.8 environment? That should give you the latest version of conda available and force you to redownload all of the packages which could help if the issue is related to a package being corrupt.

Thank you @Oddant1
I has followed your suggestions, but it still show the same error messages.

What version of OS you have? It might be a problem with glibc, to check it run ldd --version
See more info here: ImportError: dlopen: cannot load any more object with static TLS with torch built with gcc 5.5 · Issue #14485 · scikit-learn/scikit-learn · GitHub



Many thanks to @crusher083
It seems it is caused by my old glibc
I updated glibc to 2.17 and it works now!


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.