diversity plugin error [Errno 8]

Hi, I am using qiime2-amplicon-2023.9 version installed with WSL.
I have a problem when creating the alpha rarefaction curve of my samples. I am using the following command:

qiime diversity alpha-rarefaction --i-table table.qza --i-phylogeny phylogeny-align-to-tree-mafft-fasttree/rooted_tree.qza --p-max-depth 172381 --m-metadata-file metadata.txt --o-visualization alpha-rarefaction.qzv

and I get the following error
Diversity plugin error:

[Errno 8] Execution format error: 'faithpd'.

I have already updated the miniconda version with " conda update conda ".
I have uninstalled and removed the environment from the version of qiime2 I am using and reinstalled and recreated the environment.

I keep getting the error when I try to run the qiime diversity command.

Diversity plugin error:

[Errno 8] Execution format error: 'faithpd'.

thanks for reading me :)))

Hi @miguel_lopez,
welcome to the :qiime2: forum!

Can you try running faithpd in your qiime2 env? Let me know what it says when you run this!

Hi, thank you
Hello, I activated my qiime environment ( iime2-amplicon-2023.9) and then I ran:
-bash: /home/lgmiguel/miniconda3/envs/qiime2-amplicon-2023.9/bin/faithpd: cannot execute binary file: Exec format error

I don't know what it means

Hi @miguel_lopez,

Can you confirm that you are using the WSL instructions to install your env?

This person had the same issue and they were able to fix it by updating WSL. Let me know if that works for you! Help in performing alpha-rarefaction diversity analysis - #14 by vasanth_mandla

Hope that help!

1 Like

Hi, I'm sorry for late response
I tried the tutorial and could not fix it. :ccc

Can I try another way? Let me know

thank you for reading!!!

What version of WSL do you have?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.