Denoising issue across different computing platform

Hi all, we ran the same data on different platforms, including Mac laptop, our university cluster (Linux system), and AWS EC2. We found slightly differences in the result of denoising. Particularly the number of denoise and non-chimeric. Is this normal? Same input with same commands have different results between different computing platforms? BTW, the total number of reads of our dataset is less than 1 million, which is the default number of --p-n-reads-learn in qiime dada2 denoise-single

The commands are:
qiime dada2 denoise-single --i-demultiplexed-seqs input.qza
--p-trim-left 0
--p-trunc-len 215
--o-representative-sequences 2.DADA2_rep-seqs.qza
--o-table 2.DADA2_table.qza
--o-denoising-stats 2.DADA2_denoising-stats.qza
--p-n-threads 16

Any thoughts?

Hi, welcome to the forum!
If you are using the same commands and the same preprocessing steps, dada2 outputs should be identical unless you are using different Qiime2 versions on different machines.

Hi @timanix we used same version Qiime2-2021.4. The results are different. Have you tried using same Qiime2 version with same commands and data on different machines?

Two of them are same. But one of them is slightly different for the other two. The difference is from both denoised and non-chimeric.

Hi @guojun_wu
Usually I work in a shared space between my working machine and a home laptop, so yes, sometimes I run the same dataset with the same settings and the same version of Qiime2.
But I didn't check if the outputs are completely identical, since I store output in the cloud and work on the same files, not in parallel.

Here are the links to similar discussions that probably will answer your question, check it out

  1. I run DADA2 and got significantly different ASV numbers at different machines with the same data and setting. - #4 by Mehrbod_Estaki
  2. DADA2 denoise-single chimera removal inconsistence - #21 by benjjneb
  3. Reproduce QIIME2 DADA2 results in DADA2 R
1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.