Denoising code is not working?

Hello users,

I was trying to denoise my data using qiime2 but it keeps failing for some reason. Here is the code I used:

qiime dada2 denoise-paired
--i-demultiplexed-seqs ./per_sample_sequences.qza
--p-trunc-len-f 248
--p-trunc-len-r 220 \
--o-representative-sequences ./16S_rep-seqs-dada2.qza --o-table 16S_table-dada2.qza
--o-denoising-stats ./16S_stats-dada2.qza

Any idea what is wrong with this?

Thanks in advance :slight_smile:

Hi @Afaf,

Please include the following details in your response so that we can better assist you:

  • Version of QIIME 2 you are running, and how it is installed (e.g. Docker, conda, etc.)
  • What is the exact error message, if applicable? If you didn't run the command with the --verbose flag, please re-run and copy-and-paste the results.

Thanks!

it is qiime2-2019.1
the whole error is:
Plugin error from cutadapt:
/tmp/slurmtmp.12906110/q2-CasavaOneEightSingleLanePerSampleDirFmt-e4hs_ohh/2101_CGTTAGTGACTG_L001_R1_001.fastq.gz is not a(n) FastqGzFormat file:
Missing sequence for record beginning on line 13
Debug info has been saved to /tmp/slurmtmp.12906110/qiime2-q2cli-err-_le0yfsu.log

Please advise
Thanks

Hi @Afaf,

Can you please follow these instructions to install the latest version of QIIME 2 in a new conda environment, and then try re-running your commands again? You are running a version of QIIME 2 that is a few years old, so this may be where that error is coming from. Thanks!

1 Like