Demux summarize error: CRC check failed

Hello,

I imported my paired end demultiplexed data using a manifest file, and am now ready to denoise with DADA2. However, when I run demux summarize to visualize my sequence quality, I get an error:

qiime demux summarize \
–i-data paired-end-demux.qza
–o-visualization paired-end-demux.qzv
Plugin error from demux:

CRC check failed 0x80fec6e9 != 0x425d426c

Debug info has been saved to /var/folders/x6/sl6dpg0156q050yy_wm4rjb00000gn/T/qiime2-q2cli-err-gf16id1f.log

Here is the contents of the log file:
Traceback (most recent call last):
File “/Users/mashataguer/miniconda2/envs/qiime2-2018.2/lib/python3.5/site-packages/q2cli/commands.py”, line 246, in call
results = action(**arguments)
File “”, line 2, in summarize
File “/Users/mashataguer/miniconda2/envs/qiime2-2018.2/lib/python3.5/site-packages/qiime2/sdk/action.py”, line 228, in bound_callable
output_types, provenance)
File “/Users/mashataguer/miniconda2/envs/qiime2-2018.2/lib/python3.5/site-packages/qiime2/sdk/action.py”, line 424, in callable_executor
ret_val = self._callable(output_dir=temp_dir, **view_args)
File “/Users/mashataguer/miniconda2/envs/qiime2-2018.2/lib/python3.5/site-packages/q2_demux/_summarize/_visualizer.py”, line 117, in summarize
for seq in _read_fastq_seqs(file):
File “/Users/mashataguer/miniconda2/envs/qiime2-2018.2/lib/python3.5/site-packages/q2_demux/_demux.py”, line 34, in _read_fastq_seqs
for seq_header, seq, qual_header, qual in itertools.zip_longest(*[fh] * 4):
File “/Users/mashataguer/miniconda2/envs/qiime2-2018.2/lib/python3.5/gzip.py”, line 287, in read1
return self._buffer.read1(size)
File “/Users/mashataguer/miniconda2/envs/qiime2-2018.2/lib/python3.5/_compression.py”, line 68, in readinto
data = self.read(len(byte_view))
File “/Users/mashataguer/miniconda2/envs/qiime2-2018.2/lib/python3.5/gzip.py”, line 452, in read
self._read_eof()
File “/Users/mashataguer/miniconda2/envs/qiime2-2018.2/lib/python3.5/gzip.py”, line 499, in _read_eof
hex(self._crc)))
OSError: CRC check failed 0x80fec6e9 != 0x425d426c

Also, I don’t know what version of illumina my sequencing facility used, so I am assuming 33 and used that for importing my sequences. I tried 64 just in case too and got an error “Decoded Phred score is out of range [0, 62].” So I’m assuming the import was successful with phred33.

Does anyone have any ideas what’s going on? This is my first time using QIIME2, so maybe I am missing something obvious!

Thanks,
Masha

Hi @Masha_T,

That CRC error means that some of the data in your original file is missing. That happens with network interruptions pretty often. If you were to download/fetch your fastq files again and re-import the problem should go away.

Yup! Phred 33 is the modern offset. Only very old machines will use 64 as the offset.

I am getting a similar error:

CRC check failed 0x88b1f != 0x9f6e909

I have tried to re-import the data as suggested in this thread, but got the same error again when I tried demux summarize. Could I be missing something else?

Thanks!
Carla

Hi @cjweiss,

The issue isn’t the import per-se, rather it is the original fastq files that you are importing which are corrupt.

If you get them again from your sequencing center, network drive, however it was you got them originally, you should be able to re-download/transfer to get the complete file (rather than the incomplete file that you have now).

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.