Demultiplexing seqs.fna from QIIME1

Hi All,

Working through some older data from QIIME1 that I’d like to analyse in QIIME2. I have a seqs.fna file that I imported into QIIME with

qiime tools import
–input-path 2016seqs.fna
–output-path 2016seqs.qza
–type SampleData[Sequences]

which worked just great. I understand that I would still need to remove chimeras, etc. so I’d like to get this in demux.qza format so that I can run dada2 or deblur.

My questions are: do I need to do this, and how do I do this? Any help is great!

Thanks :slight_smile:
Leah

Hey there @leahtee!

Unfortunately you can’t - SampleData[SequencesWithQuality] (what you are referring to here as demux.qza) must have quality scores - the SampleData[Sequences] found in seqs.fna doesn’t have quality scores.

Check out this tutorial for guidance on importing and dereplicating these data. Then, you can take a look at this tutorial for guidance on how to identify and remove chimeric sequences.

I will leave that to other experts on this forum to weigh in on - @Mehrbod_Estaki? @antgonza?

Hope that helps! :t_rex: :qiime2:

Hi @leahtee,

What the next step is depends on what’s been done so far. Could you please describe what exactly these reads are and what has been done up to the point of you creating the .fna file? As a side note, if you have access to the original raw fastq files for this project, that would certainly be the preferred method in analyzing this in qiime2.

1 Like

Hi @Mehrbod_Estaki!

Basically this is data that was processed through QIIME1 in 2016, and I can’t find the original fasta files, just the seqs.fna.

I’ve imported that seqs.fna file, dereplicated it, and am now doing the closed-reference OTU picking through vsearch. I can’t seem to figure out how I would denoise (dada2/deblur) the data - or if I even need to.

I’ve tried skipping it and moving ahead in the Moving Pictures tutorial to the sequence alignment stage, but I run out of memory both using the mafft and a fragment insertion using

qiime fragment-insertion sepp
–i-representative-sequences rep-seqs.qza
–o-tree insertion-tree.qza
–o-placements insertion-placements.qza

I’m currently running QIIME2 in a virtual box, w/ 9 GB RAM, but I’ve also run out of memory using AWS with 68 GB RAM, and that’s the largest RAM I can get. I’m kind of really stuck! haha.

Any insight/advice is much appreciated.

Thanks!
Leah

Thanks @thermokarst! That’s a huge help :grin:

Leah

1 Like

update @Mehrbod_Estaki - I found the .qual file on an old hard drive!

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.