Demultiplexing on AWS

Hi there,

I am trying to run the "Atacama soil microbiome" tutorial on a m1x.large with paired end data that is multiplexed. I have my forward and reverse sequence files (reverse.fastq.qz, forward.fastq.qz) and my barcodes file (barcodes.fastq.qz). When I try and run the demux emp-paired command I get this error:

Plugin error from demux:

No sequences were mapped to samples. Check that your barcodes are in the correct orientation (see the rev_comp_barcodes and/or rev_comp_mapping_barcodes options).

The error log says this:

Traceback (most recent call last):
File "/home/qiime2/miniconda/envs/qiime2-2018.6/lib/python3.5/site-packages/q2cli/commands.py", line 274, in call
results = action(**arguments)
File "", line 2, in emp_paired
File "/home/qiime2/miniconda/envs/qiime2-2018.6/lib/python3.5/site-packages/qiime2/sdk/action.py", line 232, in bound_callable
output_types, provenance)
File "/home/qiime2/miniconda/envs/qiime2-2018.6/lib/python3.5/site-packages/qiime2/sdk/action.py", line 367, in callable_executor
output_views = self._callable(**view_args)
File "/home/qiime2/miniconda/envs/qiime2-2018.6/lib/python3.5/site-packages/q2_demux/_demux.py", line 378, in emp_paired
raise ValueError('No sequences were mapped to samples. Check that '
ValueError: No sequences were mapped to samples. Check that your barcodes are in the correct orientation (see the rev_comp_barcodes and/or rev_comp_mapping_barcodes options).

I've run the metadata file through keemei a few times and got no errors. I've rebuilt my metadata file from scratch and tried re-running it again and I still get this error.

Going through the forums, I found users who had a similar error b/c they switched up their barcode and sequence files doing single-end analyses, but that isn't likely for me b/c I'm using paired-end analysis (Demux quits with plugin error: no Sequences mapped).

I've also demultiplexed another data-set recently and had no problem, but I did that on a different EC2 instance (m3x.large). I'm not quite sure what could be throwing this error.

I've attached my metadata file here. It's in .txt because I had to remove some patient information, but I've been uploading to QIIME2 in .tsv after running it through Keemei.

Thanks!

Metadata.txt (73.7 KB)

Link to my files here: https://drive.google.com/drive/folders/1SLGqTB6IriwmuzxTO0pcmNd9mRI0PbhW?usp=sharing

Didn’t have enough space for my reverse sequences, but hopefully this is enough to trouble-shoot. Thanks!

Hi @jnie93,

Thanks for sharing your files, they are certainly very helpful for troubleshooting. I noticed a few things while I was looking through your files.

  1. Your metadata file’s BarcodeSequence column has sequences that are 24bp long which would usually imply you had dual-barcode indexes (12bp in forward + 12 bp in reverse). In your barcodes.fastq.qz file however, your barcodes are only 12bp long. The message you are seeing is thus telling you that these two are mismatched. So the question is did you have dual-indexed design in which case you may be missing another barcode file? Or did you have single barcoded index in your forward reads only in which case the metadata file is incorrect and needs to be changed to.
  2. Just from the first few lines of your barcodes file I noticed not all of them were present in your metadata file. My guess is the barcodes in your metadata file are incorrect and need to be fixed.
  3. The other thing I noticed which was strange was the content of your actual sequences. For example:
@M05390:37:000000000-BHRNK:1:1101:12261:1776 1:N:0:0
CGGTGACATATCTCGTATGCCGTCTTCTTCTTGCTATCACCCTCTTTCTTTCTTTTTTTTTCTTTTTTTTTTTTTCTCTTATTCTTTCTTCTTCTTTTTTTCTTTTTTTTTTTTTTTTTTTTTTCTTTTCTTCTTTTTTTTTTTTCCTCTCTTTTTTTTCTTTTTTTTTTTTTTTTTTTTTTTTTTTTCTTTTTTTTTTTCTTTTTTTTTTCTTTTCTCTTTTTTTTCTCTTTTTTTTTTTTTCTTTTTTCTTTTTTTCTCTTTCCTTTCTTTTCTTCTTTTTTTTTTTTTTTTCTTTTCT
+
-6-8<,C-<,[email protected]@C,C<[email protected]@ECCE-6CC,,-,,,,,,,,,,,6,;66,,,,,;++++,,9,,,6++++7+7,,5,5,5,,,,9,9,,5,,<A<,,++,,,,,,+++++++++3*******,,,,,,3,,,,,,3*******,0,++*0++++**/,+++++****/**/***2*/*********++++++**//**+0++++/****+++0++2+0++++**1+020+0++**)/****+++**+*++++*+*)*+*)**)*)**+*+++.*/)***+0)/)*(1)*()()))****
@M05390:37:000000000-BHRNK:1:1101:17127:1783 1:N:0:0
CGGTGACATATCTCGTATGCCGTCTTCTTCTTGCACCATCCACGCTAATCTCTTTCTTTCTCTTCTTTTTCATATCTCGTTTTCCTTCTTCTGCTTTATTACTCTTTTTCTTTTTTTTTTTTCTTTTTTTCTCTTTTTCTTCCCTCTTCTTTTCCCTTTTTTTCTTTTTTTTTTTTTTCTTTTTTTTTTTTTTTTTTTTCCTCCTCTTTTTTTTTTTTTTTTTTTTTTTTCTTTTTTCTTCTTCTCTCTTTCTTTTTTCTTTCTTTTCTTTTTTTTTCTCCCTCTCTTTTCTTTTTCTTTT
+
8--A<8E<[email protected]@EC;[email protected]@@@CEDFE-;CC,,-;,,6,,;,,+6,+;,,,;,,,;,,,6,,,,,,6,,,,;,6,69,C,:,69,<C96,C,,<E,,,,,,,,,,,,,,,,,,,+++++++,,,,9,++,,,,,,,5,,,,,,,,,,7,,,5,,,,,,,,++,,,,,,++3***1**,,2,,31*******/******++++***+++++******1**/8*//***2*++2+0+**++0++0+0**++++++*++)*+*)*0)*)0*+*++*())(*****)*)+)+*2)*)*)(****

The first ~40 bps look normal but the rest of your sequences have an oddly high T and C distribution. They certainly don’t look like any typical sequences I’ve seen, but perhaps this is something expected with your experiment? Though I have trouble imagining a situation where this would be the case…just thought you should know and perhaps worth looking into.
Perhaps this happened as a result of some improper pre-processing/QC?

2 Likes

Ah thank you so much! I’m very new to QIIME2 and this has been very helpful. I’m going to extract the barcodes again and I’ll check in with my labmates and get their thoughts on the metadata file and the sequences. Thank you!

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.