Demultiplexed sequence length does not match with Sequence Base of Quality Plot in demux.qzv

Hi, I have problem with understanding the demux.qzv. After I used the code “qiime cutadapt trim-paired”, demultiplexed sequence length summary showed that there are 283 nts of my forward read. However, there are still 300 bp of read showed in Sequence Base of Quality Plot (Sequence Base showed position 1 to position 300). I think Sequence Base of Quality Plot should only show position 1 to position 283. Why not?
Thank you very much for your time and effort dedicated to the matter.
demux_trimmed.qzv (321.3 KB)

Good morning, @XiaominCheng,

Welcome to the forums! :qiime2:

As you can see in that Demultiplexed sequence length summary, the 50% percentile of your read length is 283 nts, and even when you go out to the 98% percentile, the read length is 283 bp long. So these reads are being trimmed down to 283, just like you expect.

I think the interactive quality box plot may be made before trimming is performed to show you the full length of the original read.

If you would like to post all the commands you ran to make these files, we can take a look at the pipeline to double check that everything is working correctly.


Thank you very much! The commands are listed below:

conda activate qiime2-2021.4 \
qiime tools import --type 'SampleData[PairedEndSequencesWithQuality]' --input-format PairedEndFastqManifestPhred33V2 --input-path manifest.txt --output-path demux.qza \
qiime demux summarize --i-data demux.qza --o-visualization demux.qzv \
qiime cutadapt trim-paired --i-demultiplexed-sequences demux.qza --p-front-f CCTACGGGNGGCWGCAG --p-front-r GACTACHVGGGTATCTAATCC --o-trimmed-sequences demux_trimmed.qza --verbose \
qiime demux summarize --i-data demux_trimmed.qza --o-visualization demux_trimmed.qzv \

The extracted DNA was amplified by targeting the V3–V4 regions of the 16S rRNA gene with 341F (5′-CCTACGGGNGGCWGCAG-3′) and 806R (5′-GACTACHVGGGTATCTAATCC-3′) primers. Beads clean-up of PCR products, amplicon barcoding, and pairend (2 × 300 bp, 600 cycles, v3 chemistry) sequencing of the amplicons were performed under Illumina MiSeq platform.

How can I choose values for --p-trunc-len and --p-trim-left in this case based on the plots in demux_trim.qzv? Because Demultiplexed sequence length does not match with Sequence Base of Quality Plot in demux_trim.qzv.

You should use the quality plots and lengths from demux_trimmed.qzv to choose settings for DADA2. I've got a post about how I calculate overlapping settings over here, if that's helpful.

Let me know what you try next!

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.