Demultiplex joined reads sequences

I’m trying to demultiplex my joined reads sequences.
The information about my sequences is as follow: the raw data files are –full.fasta & -full.qual, which contain the raw sequence data information and have primers and barcodes. (Since I didn’t get any other sequence file, I guess theses sequences are joined reads.) Then I transformed the fasta & qual files into fastq. After that, I applied the answer Importing FASTA file, and imported the fastq file as sequences.qza.
Now I want to demultiplex the sequences.qza as “Moving Pictures” tutorial, but it returned
Plugin error from demux:

Argument to parameter ‘seqs’ is not a subtype of EMPPairedEndSequences | EMPSingleEndSequences | RawSequences.
I don’t know what to try next:sob:

Thanks a lot in advance!
Nan Wang

*this is a supplement for this question:

actually, I also have two files: –pr.fasta, -pr.qual, which are Sequencing information without the primer-barcode used in our analysis. The sample names from which each sequence is derived is encoded in the definition line of each sequence and short files < 150bp removed.
I guess if I merged these two files to .fastq, I would be able to skip the “Demultiplexing sequences” and " Sequence quality control". the problem is, if I do so, how can I generate rep-seqs-dada2.qza & table-dada2.qza & stats-dada2.qza? Thanks a lot!

Hey there @nan_wang!

In order to work with these data in QIIME 2 you will need to demultiplex them, somehow (we don’t have a tool for your specific use-case). Once they are demuxed (and assuming they have the quality scores still), you can use a tool like q2-dada2 to denoise, which will generate a table and rep-seqs for you.

Soryy, I didn't explain my data clearly. Actually, my data was PGM sequencing data. I've merged the barcode&primer-removed sequence data (fasta) and qualitydata (.qual) into .fastq data like this:


I've read the post from How to do multiplex of Ion torrent sequences. I guess this solution could work for me, since I don't have barcode, either. but I am stuck in one problem: instead of split by samples, now all my samples are in one fastq file. I tried in qiime1 to split it with, but it requires either "barcode read fastq files" or "sample_id ( --sample_ids:
Comma-separated list of samples ids to be applied to all sequences, must be one per input file path (used when data is not multiplexed))". I guess sample_id is not practical since typing ids manually...uh...scaring...

Also, I've merged the barcode&primer-remained sequence data (fasta) and qualitydata (.qual) into .fastq data like this:
but I really do not know what to do next :sob:

or, I also tried to demux the data via qiime1, and get the output sequence file XXX.fna. Then I imported it in qiime2 as "--type FeatureData[Sequence]" and try to use dada2 to generate the "representative-sequences XXX.qza" "table xxx-dada2.qza" "denoising-stats xxx-dada2.qza", BUT it returned " Argument to parameter 'demultiplexed_seqs' is not a subtype of SampleData[PairedEndSequencesWithQuality | SequencesWithQuality]"

I am totally in a mess now.... could you pleas give me any suggestion to start?

Thanks a lot!

Yep, this is what I was referring to above --- QIIME 2 doesn't have a way for you to demux samples without barcodes in the reads (or, in the case of EMP data, a separate barcodes file).

Are the reads in the same order between this barcode file and the main reads file? If so, you might be able to import as EMP reads and demux that way! Check out the Moving Pictures tutorial and the Import tutorial for a start. Otherwise, get your reads demuxed somehow outside of QIIME 2 and you can then import them into QIIME 2 and get cooking! :qiime2: :t_rex:

An off-topic reply has been split into a new topic: The number of sequences in your feature table is larger than 1 million, please use the parttree parameter

Please keep replies on-topic in the future.

Thanks a lot for your quick reply! Actually, I successfully imported data just now. but I have one more question Demultiplex joined reads sequences. Should I worry about that?

Thank you very much!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.