Dada2 (return code 1)

I have received an error while running dada2. I run with --verbose and received these below:
Running external command line application(s). This may print messages to stdout and/or stderr.
The command(s) being run are below. These commands cannot be manually re-run as they will depend on temporary files that no longer exist.

Command: run_dada_paired.R /var/folders/2d/w4vr4wg11k31xmms2slc85rc0000gn/T/tmp7u1a9pa1/forward /var/folders/2d/w4vr4wg11k31xmms2slc85rc0000gn/T/tmp7u1a9pa1/reverse /var/folders/2d/w4vr4wg11k31xmms2slc85rc0000gn/T/tmp7u1a9pa1/output.tsv.biom /var/folders/2d/w4vr4wg11k31xmms2slc85rc0000gn/T/tmp7u1a9pa1/filt_f /var/folders/2d/w4vr4wg11k31xmms2slc85rc0000gn/T/tmp7u1a9pa1/filt_r 295 246 0 0 2.0 2 consensus 1.0 1 1000000

During startup - Warning messages:
1: Setting LC_COLLATE failed, using "C"
2: Setting LC_TIME failed, using "C"
3: Setting LC_MESSAGES failed, using "C"
4: Setting LC_MONETARY failed, using "C"
R version 3.4.1 (2017-06-30)
Loading required package: Rcpp
DADA2 R package version: 1.6.0

  1. Filtering Error in (function (fn, fout, maxN = c(0, 0), truncQ = c(2, 2), truncLen = c(0, :
    Mismatched forward and reverse sequence files: 312, 313.
    Execution halted
    Traceback (most recent call last):
    File “/Users/Jewelna/miniconda3/envs/qiime2-2017.12/lib/python3.5/site-packages/q2_dada2/”, line 179, in denoise_paired
    File “/Users/Jewelna/miniconda3/envs/qiime2-2017.12/lib/python3.5/site-packages/q2_dada2/”, line 35, in run_commands, check=True)
    File “/Users/Jewelna/miniconda3/envs/qiime2-2017.12/lib/python3.5/”, line 398, in run
    output=stdout, stderr=stderr)
    subprocess.CalledProcessError: Command ‘[‘run_dada_paired.R’, ‘/var/folders/2d/w4vr4wg11k31xmms2slc85rc0000gn/T/tmp7u1a9pa1/forward’, ‘/var/folders/2d/w4vr4wg11k31xmms2slc85rc0000gn/T/tmp7u1a9pa1/reverse’, ‘/var/folders/2d/w4vr4wg11k31xmms2slc85rc0000gn/T/tmp7u1a9pa1/output.tsv.biom’, ‘/var/folders/2d/w4vr4wg11k31xmms2slc85rc0000gn/T/tmp7u1a9pa1/filt_f’, ‘/var/folders/2d/w4vr4wg11k31xmms2slc85rc0000gn/T/tmp7u1a9pa1/filt_r’, ‘295’, ‘246’, ‘0’, ‘0’, ‘2.0’, ‘2’, ‘consensus’, ‘1.0’, ‘1’, ‘1000000’]’ returned non-zero exit status 1

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/Users/Jewelna/miniconda3/envs/qiime2-2017.12/lib/python3.5/site-packages/q2cli/”, line 224, in call
results = action(**arguments)
File “”, line 2, in denoise_paired
File “/Users/Jewelna/miniconda3/envs/qiime2-2017.12/lib/python3.5/site-packages/qiime2/sdk/”, line 228, in bound_callable
output_types, provenance)
File “/Users/Jewelna/miniconda3/envs/qiime2-2017.12/lib/python3.5/site-packages/qiime2/sdk/”, line 363, in callable_executor
output_views = self._callable(**view_args)
File “/Users/Jewelna/miniconda3/envs/qiime2-2017.12/lib/python3.5/site-packages/q2_dada2/”, line 194, in denoise_paired
" and stderr to learn more." % e.returncode)
Exception: An error was encountered while running DADA2 in R (return code 1), please inspect stdout and stderr to learn more.

Plugin error from dada2:

An error was encountered while running DADA2 in R (return code 1), please inspect stdout and stderr to learn more.

See above for debug info.

What could be the problem?

Hi @Jewelna_Osei-Poku!

It looks like your original data has something wrong with it.

Could you run qiime tools validate on your SampleData[SequencesWithQuality] artifact (demux.qza)?

What was your import command also?


Thanks Evan for the response. Below was the message I had after running the qiime tools validate:

Artifact extracted_with_controls/metagseqs_demux-paired-end.qza appears to be valid at level=max.

My import command is below:
qiime tools import --type “SampleData[PairedEndSequencesWithQuality]” --input-path extracted/metagseqs_fastq --source-format CasavaOneEightSingleLanePerSampleDirFmt --output-path extracted/metagseqs_demux-paired-end.qza

Thanks @Jewelna_Osei-Poku,

So sorry for the slow response on my end!

It’s a shame the validate didn’t catch the issue :frowning:
Where did you get your original sequence files from? Was any filtering performed on it prior, if so, do you still have the raw-reads?

The issue is just that some reads are missing between your forward and reverse fastq files and that’s confusing QIIME 2.

Thanks Evan. You were absolutely right about the missing reads. Once I sorted that out the analyses worked fine.

Thanks you


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.