Dada2 plugin error return code error 1

dada2 denoise paired error

Attached files for error
I have two samples
Initially I ran dada2 with both of them importing them as casava1.8 paired end data
Then only with one each of forward and reverse files

Please help at the earliest



I don’t think your attachments worked. We should only need your command and the log file from the error, the demux qza you are using is likely too big for the forum to handle.

qiime dada2 denoise-paired --i-demultiplexed-seqs demux-2.qza --p-trunc-len-f 0 --p-trunc-len-r 0 --p-n-threads 0 --o-table table2-dada2.qza --o-representative-sequences rep2-seqs-dada2.qza --o-denoising-stats stats2-dada2.qza --verbose

Continuing the discussion from Dada2 plugin error return code error 1:

Picture1 Picture2 Picture3 Picture4


It looks like your input data is breaking some kind of assumption. What does your demux summarize plot look like (could you please attach if possible)?

Was an upstream processing done prior to DADA2?

Dear Sir,

No upstream processing was done prior to dada2. The demultiplexed samples that were provided were used as such for ruuning with qiime2.

Please find attached the result file demux.qza and help me troubleshoot the error.

demux-summary-1.qzv (265.1 KB)
demux-summary-2.qzv (265.1 KB)


Sorry for the delayed response.

Based on those quality plots I don’t think DADA2 is going to work very well. It looks like something upstream has truncated or binned all of the quality scores. (Did you get this data from Mr. DNA by chance?)

You should try using Deblur which doesn’t depend on the quality scores.

Dear Sir,

No the data is not from Mr. DNA.
I tried using deblur but here it is attached the deblur log file. Even that did not work.deblur1_new.txt (3.5 KB)

This log was with one sample, so I did not run the second sample and stopped it as the first sample alone took three days to run.

Please help.

Also, I tried to find otus with fasta file as opposed to fna file in the tutorial, it said that it is not a valid demux format. How can I do it with fasta file as I do not have any fna file.


Hi @HIMANI_KHURANA - would you be able to provide your demux.qza file, the one with both samples? Feel free to message me a link in private if you don’t want to share here.

Please provide your mail id to contact in private.


You can send a direct, private message over the forum. Click on @thermokarst's user icon and you will see this window appear:

Click on "message" to send a private message.

1 Like

Dear Sir,

I have two samples as both dada2 and deblur failed, I opted for vsearch in order to get feature table as table.qza and feature sequences as rep-seq.qza. I operated both samples individually.
For one sample, I tried to cluster the sequences at 99% getting rep-seqs-dn-99.qza.
The size of the rep-seqs.qza is 2.2 GB and of rep-seqs-dn-99.qza is 794.1 Mb.
I have been running qiime2 fragment insertion as an alternative as mafft failed to process more than million sequences.
But it has been almost two weeks that it is running using rep-seqs.qza using 60 threads, and yesterday only I started operating the same on rep-seqs-dn-99.qza.
My questions are

Is it okay to process samples independently as I do not have metadata file and my ultimate aim is diversity analysis?
I do not know whether to work on rep-seqs.qza or rep-seqs-dn-99.qza?
What is the next step after clustering otus at 99
How to get the otu network map from this information?
If for example, I want to see the relationship of one OTU with other using Pearson correlation, is it possible and how?
I have been struggling with this since past one month for now, please help me at the earliest.
Should I stop because fragment insertion step as it is taking a lot of time and no other work am I able to do because of the server being occupied.

Thanks you very much and Regards