DADA2-No reads passed the filter

HI!! Everone ~~

I am working on some 16S sequencing data, and seems some of them is low in quality.
trim value is set by primer sequence, I am not sure how to set the trunc value.

qiime dada2 denoise-paired \

--i-demultiplexed-seqs demux.qza
--o-table table
--o-representative-sequences rep-seqs
--p-trim-left-f 17
--p-trim-left-r 21
--p-trunc-len-f 286
--p-trunc-len-r 115
--p-n-threads 0
Plugin error from dada2:

No reads passed the filter. trunc_len_f (286) or trunc_len_r (115) may be individually longer than read lengths, or trunc_len_f + trunc_len_r may be shorter than the length of the amplicon + 20 nucleotides (the length of the overlap). Alternatively, other arguments (such as max_ee or trunc_q) may be preventing reads from passing the filter.

Debug info has been saved to /tmp/qiime2-q2cli-err-9lzlxqdg.log

I tried --p-trunc-len-f 288, --p-trunc-len-r 266 , same error happens


Thanks for all you help !!

Hi @Lai_mail! From the quality score plots you uploaded, it looks like there are forward and reverse reads that are really short (79bp and 35bp, respectively), in addition to longer reads. There may be other reads that are even shorter than those numbers because the length check only looks at a subsample of the total sequences. My hunch is that these reads are much too short to overlap, or are throwing off some of the other filtering steps performed by DADA2. Has there been any other quality filtering, trimming, or processing performed on these reads prior to denoising with DADA2? Note that you’ll need at least 20nts plus the length of the amplicon to have the reads successfully joined.

Dear Jai

Thank you for your reply!
But I have no idea why the read is so short, I work with a fasta.gz file directly from 16S sequencing, starts with the below command :

qiime tools import
–type ‘SampleData[PairedEndSequencesWithQuality]’
–input-path 2017
–source-format CasavaOneEightSingleLanePerSampleDirFmt
–output-path demux.qza

Thanks again for your help.

Hi @Lai_mail,

Would you be able to upload your original .qzv? I wonder how many reads are in practice that short. Technically even a single bad read will cause most of the plot to turn red like that.

That being said, it does kind of seem like your reverse reads are in pretty bad shape, so it’s not too surprising that with the more constrained trunc-len DADA2 is unable to merge them (you probably lack enough overlap like @jairideout mentioned) . Perhaps a way forward would be to just use the forward reads, if you ran qiime dada2 denoise-single (instead of denoise-paired) with that same artifact, it will only use the forward reads and ignore the reverse.

Let me know if that works better.

Dear Evan

Thank you for your help , I was wondering what is original.gzv?

Thanks again.


Hi @Lai_mail,

Sorry, I meant the .qzv file which you took a screenshot of. You should be able to attach that to your reply and we can see just how many reads aren’t as long as the others in that pictured chart.

Thanks @ebolyen
Here is the qemux file

Thanks for all you help !!

Hi @Lai_mail!

Thanks for the link. It looks like you don’t need to worry about the red sections, only a handful are shorter than the rest (until the very last base, where a large chunk are shorter). I would recommend ignoring the reverse reads and just using qiime dada2 denoise-single instead of denoise-paired. You are probably going to want to set your --p-trunc-len to less than 200 since your quality really crashes at that point in a consistent way.

Hopefully that’ll get you on your way!

P.S. you don’t need to re-import your data as single end, just pass the same demux.qza to denoise-single, it’ll only use the forward reads.

Thank you very much!!!
All of you are very helpfu~~~~

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.