DADA2 denoise : No reads passed the filter (PacBio sequencing data)

Hi! I'm new to QIIME2 and I have some problem with denoising my PacBio sequencing data.

I am running qiime2 2021.11 with conda in Ubuntu. I'm dealing with my 18S rRNA PacBio sequencing data by PacBio Sequel I sequencing platform. I've searched many topics related to this issue but I can't solve this problem so far.
When I run dada2 denoise-single with .qza artifact file from my sequenced data, there are No Reads Passed The Filter. Command I used is:
qiime dada2 denoise-single --i-demultiplexed-seqs trimmed_reads.qza --output-dir dada2_output --p-n-threads 0 --p-trunc-len 0 --p-trunc-q 3 --p-max-ee 3 --verbose

I tried changing parameters of trunc-q from 3 to 30, --p-max-ee from 3 to 30 or turn on/off the chimera-method, but still no reads passed the filter like following:
debug_info.txt (12.3 KB)
As PacBio sequel I platform generates data with quality score "!", which means lowest quality score, to all sequenced data (because PacBio said as quality is already high enough, so no need to generate quality score), I've changed all "!" quality score to "#" (which means quality score = 2) to avoid all data being removed. So my demux.qza file possess interactive quality plot like this:

Thank you for reading this issue. I really appreciate your comments on this issue!

1 Like

Hi @Kim_Jihoon,
welcome in the forum!

For what I know, DADA2 can be used to process PacBio sequences, but you need to work in R.
The dada2 denoise single plug in is not tailored for that.
Few tutorial you may want to look at, are linked in this ResearchGate topic:

Hope you manage to work with this.
Best wishes

1 Like

Hi @llenzi, thank you for your reply!

I'll check what you linked and try to do with it.

Thank you!

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.