Correlation analysis


#1

Hello,

Im trying to use SCNIC with 2019.1 version of qiime2, as Ive had great success with this with previous versions of qiime2. When I try to install I get this

Collecting package metadata: done
Solving environment: failed

PackagesNotFoundError: The following packages are not available from current channels:

  • q2-scnic -> q2-types=2018.11
  • q2-scnic -> qiime2=2018.11
  • q2-scnic -> scnic[version=’>=0.6.*’]

Current channels:

To search for alternate channels that may provide the conda package you’re
looking for, navigate to

https://anaconda.org

and use the search bar at the top of the page.

Is this telling me that I cant use q2-SCNIC with the newest version??

Thanks for the help!!!

Scott


(Matthew Ryan Dillon) assigned michael.shaffer #2

(Michael Shaffer) #3

Hey @swillyb,

I just haven’t gotten around to testing q2-SCNIC with qiime2 2019.1. It is on my list for today so hopefully I will have a version for qiime2 2019.1 up by the end of the day. Versions of q2-SCNIC for older versions of qiime should still work though.

Mike


(Nicholas Bokulich) unassigned michael.shaffer #4

#5

ok awesome, thanks so much!!


#6

would it be possible for you to let me know when scnic is tested with 2019.1 please? thank you!!!

Scott


#7

Hi Mike,

any word on SCNIC yet? I can use an older version I know, but I only have the newest version on my personal computer and that lets me work remotely.

Thanks!!

Scott


(Matthew Ryan Dillon) #8

2018.11 is still officially supported, you can install that side-by-side with 2019.1.


#9

Hi Mike,

Ok great! I installed 2018.11 alongside the newest version, and then used these commands,

conda install -c conda-forge blas=1.1

conda install -c lozuponelab q2-SCNIC

conda install -c conda-forge blas=1.1 worked no problem, however conda install -c lozuponelab q2-SCNIC doesn’t work, and I get this error…

(qiime2-2018.11) Scotts-MacBook-Pro-2:~ scottbehie$ conda install -c lozuponelab q2-SCNIC
Collecting package metadata: done
Solving environment: failed

PackagesNotFoundError: The following packages are not available from current channels:

  • q2-scnic -> scnic[version=’>=0.6.*’]

Current channels:

To search for alternate channels that may provide the conda package you’re
looking for, navigate to

https://anaconda.org

and use the search bar at the top of the page.

thanks for your help here, Im really not sure how to resolve this, Im sure its something simple that Im not doing.

Scott


(Matthew Ryan Dillon) #10

Oops, I think you meant Matt!

:cool:

Try this: Q2-scnic packagenotfounderror