Conda error parsing .yml file

Hello, all!

I’m finally making the switch to QIIME2 and am already having an issue creating the conda environment.

I made sure I had the updated conda package and cleared all my environments but when I installed wget it wanted me to downgrade my python version so I used curl -O to grab the .yml file.

Now I am attempting to run

conda create -n qiime2-2018.8 --file qiime2-2018.8-py35-osx-conda.yml

but there is a parsing error:

CondaValueError: could not parse ‘<!DOCTYPE HTML PUBLIC “-//W3C//DTD HTML 3.2 Final//EN”>’ in: qiime2-2018.8-py35-osx-conda.yml

Is there a problem with the file itself? I downloaded it manually and I tried a search of the error message but the answer is beyond my comprehension, it appears.

Thank you and I look forward to utilizing it for my work!


After searching the error message more, I realize this could be an issue with the file type. So I copied and pasted the text from the .yml file into a blank .txt file. When I tried to run the conda command with that file, I received this message:

could not parse ‘- qiime2/label/r2018.8’ in: qiime2-2018.8-py35-osx-conda.txt

Another update:
I downloaded wget to make sure the file format and content were correct. It appears the correct file has downloaded, but now I get the same error when attempting to make a new env:

CondaValueError: could not parse ‘- qiime2/label/r2018.8’ in: qiime2-2018.8-py35-osx-conda.yml

Yowza @rjoakim!

It looks like you skipped around and didn’t necessarily follow all of the install commands in order — can you try again, starting from the beginning? Also, 2018.11 is out now, so that will be convenient to get.

It was only the third step… kind of hard to “skip around” :wink:
But I think I was a bit non-linear in my description as I kept trying to troubleshoot.
Here’s what I did:

conda update conda : already installed but I updated just to be sure

conda install wget : wanted me to downgrade my python package so at first I did curl -O instead, and when that file didn’t work I DID execute this command, downgraded python, ran the next line, then re-upgraded python

wget :ran this no problem after curl -O gave me a nearly blank file with

conda create -n qiime2-2018.8 --file qiime2-2018.8-py35-osx-conda.yml :this is where I get the parsing error

I will start again with 2018.11, maybe the .yml file will be “nicer”, if that’s the issue.

Looks like the 2018.11 .yml is behaving, because the packages are all currently downloading.

So I guess who cares what the error was… ???

Good to hear! :champagne:

Computers aren’t too clever — this is still enough to cause a problem. :computer:

The reason you got this error is because the .yml file didn’t contain what it should’ve (a YAML manifest), rather, it looks like you accidentally downloaded an HTML file, but saved it into the .yml file:

This is an HTML file header.

I don’t think this had anything to do with 2018.8 vs 2018.11, but rather, the wrong stuff being downloaded. That is probably because the version of curl on your machine is missing certificate files, and downloaded an intermediate page. This is why our install command specifies downloading wget from conda, then using wget to download the file. Make sense?

Thanks, and happy QIIMEing! :sunflower:

1 Like

I got the

CondaValueError: could not parse ‘- qiime2/label/r2018.8’ in: qiime2-2018.8-py35-osx-conda.yml

error when I did use wget. I recognized the html error form the curl command whilst perusing another thread so I tried both copying and pasting the rich text directly to nano AND using the exact wget command, both resulting in this same parsing error.

Like I said, it probably doesn’t even matter anymore, I just wanted to make sure you understood my error correctly in case there is a similar issue elsewhere.

Excitedly going through the tutorials now.



So when I ran
source activate qiime2-2018.11

it went through all of the package installations but displayed this output:

Preparing transaction: done
Verifying transaction: done
Executing transaction: | Enabling notebook extension jupyter-js-widgets/extension...
      - Validating: OK

Requirement already satisfied: msgpack==0.5.6 in /Users/rachael/ls/envs/qiime2-2018.11/lib/python3.5/site-packages (from -r /Users/rachael/qiime2/condaenv.8LDTwr.requiremen$
dyld: lazy symbol binding failed: Symbol not found: _fdopendir$INODE64
  Referenced from: /Users/rachael/ls/envs/qiime2-2018.11/lib/libpython3.5m.dylib
  Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: _fdopendir$INODE64
  Referenced from: /Users/rachael/ls/envs/qiime2-2018.11/lib/libpython3.5m.dylib
  Expected in: "/usr/lib/libSystem.B.dylib

CondaValueError: pip returned an error

I was able to import the QIIME1 split_libary seqs.fna file as a .qza file:

qiime tools import --input-path seqs.fna --output-path seqs.qza --type SampleData[Sequences]

but when I tried to run dada2 (denoise-paired) I received this error:

Trace/BPT trap: 5

I looked this up on the forum and saw it connected with the first error I received after installation. I triple-checked that I was running the right version (my machine is a Mac) and even tried a OS X software update. However, it appears the machine is still running Maverick.

Do I need to update to at least 10.10 OSX? It looks like that’s been an issue for others. Unfortunately I am ssh-ing into my bioinformatics machine so I used

sudo softwareupdate -iva

and it still says System Version: OS X 10.9.5 when i ran system_profiler SPSoftwareDataType.

Do you think this is stemming from an incompatibility with the older OS X version as it was with Lazy symbol binding failed?

If it is I will not be able to update until I can manually accessing the machine on Tuesday.

Thank you! :raccoon:

I suspect so — sorry :(. This isn’t due to any particular need for it with QIIME 2, but rather, it appears that one or more dependencies of QIIME 2 require 10.10 or newer. Sorry. In the meantime, you could try Docker of Virtualbox on another machine? Or provision AWS? All detailed in the user docs.

OK! I finally got to try this again. I got all the permissions from my labmates to update the OSX software to 10.14 and it appears to be working now.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.