Lazy symbol binding failed

Hey everyone,
I am currently trying to run qiime 2 after successfully having used qiime1 and dada2 with my demultiplexed paired end samples. just a quick setting explanation: I am running the latest qiime 2 release: q2cli version 2017.11.0
conda 4.3.30
Python 3.5.4
macOS 10.9.5

my samples were run on an illumina Miseq Platform. the reads are paired end and demultiplex but still have primers in them, so I have 2 files per sample with R1 and R2. i simply want to import the files but am already stuck here.

this is my command
(qiime2-2017.11) RIMAs-MacBook-Pro:Desktop rc $ qiime tools import --type ‘SampleData[PairedEndSequencesWithQuality]’ --input-path qiime2_BGI/demultiplexed_BGI_sequences_gzip --source-format CasavaOneEightSingleLanePerSampleDirFmt --output-path demux-paired-end.qza

the error:
dyld: lazy symbol binding failed: Symbol not found: _fdopendir$INODE64
Referenced from: /Users/rc/anaconda/envs/qiime2-2017.11/lib/libpython3.5m.dylib
Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: _fdopendir$INODE64
Referenced from: /Users/rc/anaconda/envs/qiime2-2017.11/lib/libpython3.5m.dylib
Expected in: /usr/lib/libSystem.B.dylib

Trace/BPT trap: 5

I am wondering if there is something else I should be installing. would otherwise running qiime 2 on the qiime2 virtual box be a solution.
any help is appreciated!



Hi @Drevilette! I chuckled at that awesome Topic Title you posted — computers say the darndest things!

This little bit here makes me think you accidentally installed the Linux version of QIIME 2, instead of the macOS version!

I would suggest wiping the install and trying again:

$ source deactivate qiime2-2017.11
$ conda env remove -n qiime2-2017.11

Then, follow the install guide, remembering to select the Mac tab, instead of the linux one. Let me know how it goes! :t_rex:

Hey @thermokarst ,

Computers DO say the darnest Things :smiley: also thanks for the quick reply and the t-Rex ! I m a big fan!

I also initially thought this is what had happened. so I deactivated, removed the Environment and did a clean up and checked that it was truly removed (below is an excerpt from the command history)

source deactivate
conda env remove -n qiime2-2017.11 
conda clean -y -all
conda info --envs

I reinstalled the QIIME 2 Version and it was definitely the macOS Version (this is the last Installation)

conda create -n qiime2-2017.11 --file

but the Problem persisted … what s the dealio …

thanks for your help! :dragon:

Dang! Well, it was worth a shot…

We need some more information here, what are the results of the following commands:

$ echo $PATH

Also, do you have a .condarc file hanging around in your home directory? If so, what does that have to say?

Hi @thermokarst, I am having a similar problem.

I am new to qiime2 (but experienced with qiime1). I have qiime2-2017.11 installed on my Mac.

I too am trying to import data, but not reads. Just an OTU table I generated outside of qiime (clustered otus using usearch, converted txt otu table to biom format using biom convert).

I ran:

qiime tools import \
--input-path otutable.biom \
--type 'FeatureTable[Frequency]' \
--source-format BIOMV210Format \
--output-path feature_table_1.qza

And get the following error:

(qiime2-2017.11) ckellogg$ qiime tools import --input-path otutable.biom --type 'FeatureTable[Frequency]' --source-format BIOMV210Format --output-path feature_table_1.qza
dyld: lazy symbol binding failed: Symbol not found: _fdopendir$INODE64
  Referenced from: /Users/ckellogg/miniconda2/envs/qiime2-2017.11/lib/libpython3.5m.dylib
  Expected in: /usr/lib/libSystem.B.dylib

dyld: Symbol not found: _fdopendir$INODE64
  Referenced from: /Users/ckellogg/miniconda2/envs/qiime2-2017.11/lib/libpython3.5m.dylib
  Expected in: /usr/lib/libSystem.B.dylib

Trace/BPT trap: 5

Any ideas what the problem might be.

I ran the commands you suggested above:

(qiime2-2017.11) ckellogg$ echo $DYLD_LIBRARY_PATH

(qiime2-2017.11) ckellogg$ echo $PATH

I’m bummed I can’t even get this first step to work! I am forcing myself to figure out qiime2 rather than staying in my qiime1 comfort zone.


Based on a quick search google, I found this

Does reinstalling xcode work for you? Here is the recommended code:
xcode-select --install

Hey @thermokarst
I know… I also wish it were that easy.

here goes round 2.
first “interesting” news:


returns nothing… so I am guessing that does not exist…

$ echo $PATH


(is that supposed to be that messy??)
and last but not least , less .condarc (in home directory) returned

ssl_verify: true
  - anaconda-fusion
  - defaults
.condarc (END) 

thanks :peace_symbol:

Hey Colleen,
I was also initially bummed about not being able to start but until we figure this out, a good solution is working on the virtual box. I am a big fan. Just download virtual box and the qiime2 image (under install) and follow the steps, they are foolproof.
I know it s not a solution for the problem but it can help you stay motivated because you re actually getting things done.
Keep your chin up :slight_smile:

1 Like

@Drevilette, can you try out @colinbrislawn’s suggestion above? I have spent some time Googling and I am starting to think this might be related to your version of macOS (this is still just a theory). Let me know how it goes, thanks! :t_rex:

Hi @thermokarst, I am wondering the same thing. I have a relatively old version of MacOS (10.9.5!) because our lab won’t update due to a few dependencies for other programs we use. I’ll install qiime2 on my laptop (running High Sierra) this evening and see if this resolves the issue. I’ll ultimately need qiime2 to work on my desktop at work because it has quite a bit more RAM and processing speed than my desktop but at least this can help us narrow in on the source.

I did run

$ xcode-select ---install

but the problem persists.

When looking at the link provided by @colinbrislawn a lot of the people mentioned the had to reinstall the program that was giving them the issue. Does this mean i should remove and reinstall Miniconda2? Or just qiime2 or perhaps just update something in one of them?

Thanks for your help!

Start by removing and reinstalling qiime2, or by installing qiime2 into a new conda environment.

You can try taking our miniconda entirely, but hopefully that’s not needed.

Okay @Drevilette & @ctekellogg, can you report back on your findings when you run the following:

$ env

I am seriously fishing now, so I wouldn’t get my hopes up if I were you :frowning:. I strongly suspect this old version of macOS is to blame here…


Hi @thermokarst

Here is what is returned after $ env

sharif:~ ckellogg$ env

Side note - on my laptop with High Sierra I don’t seem to be running into the same problem…

Do you think there is a way around this without having to upgrade my desktop’s OS?

Thanks for the env info @ctekellogg!

Good to know.

I have one last question — what do you get when you run the following?

$ pkgutil | grep version

This command should theoretically return something that looks something like this:


although you will probably see a different version number.

After doing a little sleuthing, I think the minimum version of macOS required is 10.10, at least according to this document. Travis CI is involved in the build process for a lot of QIIME 2’s third-party dependencies, so this seems like a reasonable target.

If you have a version of XCode < 6.4 on your desktop machine, you might be able to find a 6.4 or greater version on Apple’s website, but I can’t really say if that is truly an option or not.

Please let us know how it goes! :t_rex:

@thermokarst @colinbrislawn @ctekellogg

Hey there!
Thanks for the feedback and sorry I haven’t been able to reply earlier.

so i also tried downloading Xcode again (I did a quick search initially and stumbled upon that same post too), and it didn’t solve anything. So I am thinking (rudimentary physicians approach to diagnosing anything they know little about… ) it s the macOS version and an issue of third party dependencies too.

as for the $ env output

PS1=(qiime2-2017.11) \h:\W \u\$ 
CONDA_PS1_BACKUP=\h:\W \u\$ 

and last but not least

$ pkgutil | grep version



so pretty old version… I ll try updating the software and the Xcode version over the weekend and will let you know how it goes :slight_smile:

Thanks for everything :bird:

1 Like

Hi @thermokarst,

Here is the output you were curious about:

ckellogg$ pkgutil | grep version

So, I’ll see if I can get my desktop up to at least 10.10 so I can get a more current version of XCode. I’ll report back about if that fixes the problem.

Thanks again for your help with this!

1 Like

An off-topic reply has been split into a new topic: How much RAM is needed for feature classification?

Please keep replies on-topic in the future.

Thanks @ctekellogg! I split off your memory question into a new post!

I also just want to point out, and thank @colinbrislawn - this xcode route is exactly what he was suggesting earlier.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.