Classify-sklearn <Job killed>

Hello everyone-

I am using the classify-sklearn tool to generate taxonomy artifacts. I dug into previous errors related to the same tool and tried to apply those as well.

Previously, it was mentioned that the error might occur due available memory issue- therefore, I specify --n-jobs (as mentioned previously, did not work) then I used QIIME 2 Galaxy (independent of inhouse computer memory), I got the same error.

qiime feature-classifier classify-sklearn
--i-classifier silva-138-99-515-806-nb-classifier.qza
--i-reads rep-seqs.qza
--o-classification taxonomy.qza

I then tried using training file gg-13-8-99-515-806-nb-classifier.qza instead of Silva and it worked. Why the same tools give me error when I use Silva instead of Greengenes?

Any thoughts on how to debug this issue?


Hello again @shaista_karim,

Exit code 137 means that your process was 'killed' (signal 9) by something on the server. When this happens to me, it's usually because the process used more memory then allowed (or ALL the memory on the compute node) so the host supervisor sent the signal to maintain system responsiveness.

Greengenes is a smaller database than Silva and has a smaller memory footprint. You may have enough memory for greengenes, but not for silva. :person_shrugging:

How much memory does your machine / server have? How much memory have you allocated to running Docker / Qiime2?

Hi again @colinbrislawn

I am on Window operating system with processor Intel(R) Core(TM) i7-9850H CPU @ 2.60GHz 2.59 GHz and Ram 16GB.

I was aware of space issues as discussed previously so I mount an external drive (5TB) and tried as well but got the same error message. I am new to computational work/QIIME2 so please pardon me if I do not use correct words.

You are good!

Here RAM and memory are the same thing, and both refer to the 16 GB you have on your system. This is used for running applications, and it looks like you need more to use SILVA.

Storage, on a HDD, SSD, or external drive like your 5TB one is used for storing files like .fastqs.gz, .qza, results and databases. This is nice to have, but not related to this error.

@colinbrislawn so one way to fix this is to use a system with more memory.

I also read some previous discussion about limiting the number of jobs while running the command which will take some more time but still able to run. Please correct me if I am wrong.

or doing anything on a system with RAM 16GB wouldn't help at all.

Thank you,

Yes, you could do with some more RAM.

Some programs use more RAM when they have more threads, so using less threads is definitely worth trying before spending money on a computer! :money_with_wings:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.