Can't find q2-metabolomics plugin

I I installed it and it went well. But it does not show up in as an qiime2 option. If I try the code , it does not work. But if I try to reinstall it says the plugin is already installed. I am in OS X Catalina and QIIME2 env. How do I fix this? Thank you.

Are you running QIIME 2 via q2cli? If so, did you remember to run qiime dev refresh-cache?

I do not think I am using q2cli. I have QIIME2 installed through conda. Then I use “conda activate qiime2” to activate it. Then I installed q2-metabolomics. I have closed the terminal, killed the env and reactivated it. None worked. DO I need this “q2cli”? Thanks.

My guess is you are using q2cli (other interface options are the QIIME 2 Artifact API in Python, or the QIIME 2 Studio GUI). Please run the command I suggested above.

I ran that command. Then I ran “qiime metabolomics” and it resulted this error message “Error: QIIME 2 has no plugin/command named ‘metabolomics’…”

@thermokarst, @mwang87, I was able to reproduce the issue on my local (running linuxmint 19.2 in clean 19.10 and 19.7 environments). The plugin appears not to be talking to QIIME 2 as expected. I took a quick look at the plugin registration statement, and didn’t see any obvious issues there. Some outputs follow. Hope this helps.

The install proceeds with no errors or warnings. Conda list shows:

some stuff....
q2-longitudinal           2019.10.0                py36_0    qiime2/label/r2019.10
q2-metabolomics           0.0.6                         0    mwang87
q2-metadata               2019.10.0                py36_0    qiime2/label/r2019.10
... more stuff

qiime info does not show q2-metabolomics:

(q2-metabolomics) [email protected]:~$ qiime dev refresh-cache 
QIIME is caching your current deployment for improved performance. This may take a few moments and should only happen once per deployment.
(q2-metabolomics) [email protected]:~$ qiime info
System versions
Python version: 3.6.7
QIIME 2 release: 2019.10
QIIME 2 version: 2019.10.0
q2cli version: 2019.10.0

Installed plugins
alignment: 2019.10.0
composition: 2019.10.0
cutadapt: 2019.10.0
dada2: 2019.10.0
deblur: 2019.10.0
demux: 2019.10.0
diversity: 2019.10.0
emperor: 2019.10.0
feature-classifier: 2019.10.0
feature-table: 2019.10.0
fragment-insertion: 2019.10.0
gneiss: 2019.10.0
longitudinal: 2019.10.0
metadata: 2019.10.0
phylogeny: 2019.10.0
quality-control: 2019.10.0
quality-filter: 2019.10.0
sample-classifier: 2019.10.0
taxa: 2019.10.0
types: 2019.10.0
vsearch: 2019.10.0

Application config directory
/home/chris/miniconda3/envs/q2-metabolomics/var/q2cli

We’ve noticed issues on our end with the conda installation. It seems that it doesn’t play nicely with newer versions of qiime2 than when we developed it. I would recommend using the pip installation as that works for us.

We’ll be investigating in more detail in the coming new year.

Thanks!

Ming

3 Likes

Thanks so much, @mwang87!

@ehossain, take a look at the pip install instructions. They worked nicely on my machine, and will likely treat you well.

1 Like