biom command not found

Hi,
I am using qiime/2.2019.04 . When I run:
$ biom add-metadata -i exported/feature-table.biom -o table-with-taxonomy.biom --observation-metadata-fp exported/taxonomy.tsv --sc-separated taxonomy

I get following error:
-bash: biom: command not found

Regards,
Amin Ferdous

The biom-format package doesn’t come with Qiime 2, but you can still install it.

conda install biom-format

Let me know if that install works for you!

Colin

Hey @amin,

The above will certainly work to install biom, however biom is a pretty core dependency of QIIME 2, so I’m very surprised that it isn’t available (the biom library always ships the command line interface as well).

Are you certain that things are available inside that environment? What does conda list say? I kind of expect something to be very wrong with your installation (or perhaps activation just went wrong?)

@colinbrislawn and @ebolyen
Thanks a lot for your reply. I am using a cluster of high performance computing system. I did not install Qiime 2 by myself, it has been installed by them. Surprisingly when I tried to install biom-format package by
$ conda install biom-format
It gave me the error message
-bash: conda: command not found
Therefore, I am assuming conda is not installed here but how come it possible, I am using qiime 2 plug in commands and they are working perfectly. I e-mailed them informing my problem, hopefully they will get back to me soon.

Regards,
Amin Ferdous

2 Likes

Yeah… it sounds like the people who deployed qiime 2 may need to install some more software.

Great solution :+1:

Let me know how it goes!
Colin

2 Likes

Hi,
HPCC support contacted me and asked me to check Biom by running following command:
singularity exec /opt/apps/nfs/singularity/qiime/2.2019.04/qiime biom --help

I checked and it shows
Usage: biom [OPTIONS] COMMAND [ARGS]…

Options:
–version Show the version and exit.
-h, --help Show this message and exit.

Commands:
add-metadata Add metadata to a BIOM table.
convert Convert to/from the BIOM table format.
from-uc Create a BIOM table from a vsearch/uclust/usearch BIOM…
head Dump the first bit of a table.
normalize-table Normalize a BIOM table.
show-install-info Provide information about the biom-format installation.
subset-table Subset a BIOM table.
summarize-table Summarize sample or observation data in a BIOM table.
table-ids Dump IDs in a table.
validate-table Validate a BIOM-formatted file.

But when I give command “biom add-metadata” it shows " biom: command not found" also still it does not recognize ‘conda’

Do you guys have any solution what I should do.

Regards,
Amin

Sounds like you need to add the singularity prefix to make this work:

singularity exec /opt/apps/nfs/singularity/qiime/2.2019.04/qiime biom add-metadata ...

See?

It is working now…Thanks a lot.

2 Likes