Align-to-tree-mafft-fasttree missing

I used QIIME 2 2018.8 in virtual box.

When I run this

qiime phylogeny align-to-tree-mafft-fasttree --i-sequences rep-seqs.qza --o-alignment aligned-rep-seqs.qza --o-masked-alignment masked-aligned-rep-seqs.qza --o-tree unrooted-tree.qza --o-rooted-tree rooted-tree.qza

It says’" Error: QIIME 2 plugin ‘phylogeny’ has no action ‘align-to-tree-mafft-fasttree’. I know align-to-tree-mafft-fasttree is a work-flow. I can I add this workflow?


1 Like

Hey @sdpapet,

That’s very strange, that command should exist. Could you provide the output of this command?

qiime info


Hi, I checked my QIIME2 again. I found I am using 2018.06 virtual box version. Is this a version problem?

Yes, that is the problem. This pipeline was added in 2018.8 (the latest release).

I hope that helps!

1 Like

Can I upgrade my current QIIME? Or I have to download the latest version image and install it.


Your virtualbox is new enough that you should be able to follow the install instructions for miniconda and then just edit your .bashrc file so that it doesn’t source the old one automatically. q2studio will remain out of date unless you get the new virtualbox image however.

Hi, thanks. It works in 2018.8 version.

Now, I have a tree name “rooted-tree.qza”. I’d like to know if I can view the tree in QIIME? For example, is it possible I convert this file to rooted-tree.qzv or convert to *.tre file and opened in other third-party software

Hey @sdpapet,

We don’t have a good visualizer for trees at this time, but iTOL understands QIIME 2 artifacts.

You can also always export the data in any QIIME 2 artifact with qiime tools export. In this case you’ll get a newick file (aka .tre) from rooted-tree.qza.

Hi, I was working with QIIME2 2017.9 in Virtual box and I got the same error:

Error: QIIME 2 plugin ‘phylogeny’ has no action ‘align-to-tree-mafft-fasttree’.

Then I upgrade to 2017.12 and the error reappeared

This is output from qiime info:
System versions
Python version: 3.5.4
QIIME 2 release: 2017.12
QIIME 2 version: 2017.12.1
q2cli version: 2017.12.0

Installed plugins
alignment 2017.12.0
composition 2017.12.0
cutadapt 2017.12.0
dada2 2017.12.1
deblur 2017.12.0
demux 2017.12.0
diversity 2017.12.0
emperor 2017.12.0
feature-classifier 2017.12.0
feature-table 2017.12.0
gneiss 2017.12.0
longitudinal 2017.12.0
metadata 2017.12.0
phylogeny 2017.12.0
quality-control 2017.12.0
quality-filter 2017.12.0
sample-classifier 2017.12.0
taxa 2017.12.0
types 2017.12.0
vsearch 2017.12.0

Application config directory

Getting help
To get help with QIIME 2, visit

Citing QIIME 2
If you use QIIME 2 in any published work, you should cite QIIME 2 and the plugins that you used. To display the citations for QIIME 2 and all installed plugins, run:

Do you have any idea?

Please upgrade to 2018.8.

It worked! thanks !!

But now, what about all this QIIME’s version that I have (2017.9, 2017.12 and 2018.8)? Are they using RAM or any storage on virtual box settings?


If they are on and running, yes.

They will take up disk space, too.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.