Adding a New Categorical Column to the Metadata File

I am having a problem with my modified metadata file giving an error when I tried to group my samples. I added a new column to the metadata file to group the samples (like this recommendation), but I got an IDs problem. I should have added this column before starting the analysis. I tried rename-ids command with --p-strict / --p-no-strict, but I got another error. I tried other categorical columns like primer column it was grouped that is why I think I should have added the new one when i was building the metadata file.

It is the IDs error:

Plugin error from feature-table:

The following IDs are not present in the metadata: '1', '2', '3', '4'

Debug info has been saved to /tmp/qiime2-q2cli-err-ppw3i3yt.log

These two threads were similar to mine in terms of my topic but I could not find my answer.

My question is how can I add a new categorical column in a way that grouping of samples be done successfully? What is the solution?

Here it is my command:

qiime feature-table group
--i-table mergedtables.qza
--p-axis sample
--m-metadata-file dsrbmetadata.tsv
--m-metadata-column group
--p-mode sum
--o-grouped-table groupedtable.qza

Thanks a lot

Also, I changed the column from CATEGORICAL to NUMERIC mode. It gave an error:

Invalid value for ‘–m-metadata-file’: Metadata column is of type
‘numeric’, but expected Categorical.

The sequences are ‘ASVs’, not OTUs, for the record.

I added some letters beside the numbers from 1 to 4 in the column called group. The samples were grouped but visualization file generation (.qzv) revealed IDs error:

Plugin error from feature-table:

The following IDs are not present in the metadata: ‘s1’, ‘s2’, ‘s3’, ‘s4’

Debug info has been saved to /tmp/qiime2-q2cli-err-qbfpkdt2.log

I am not sure the newly grouped table is valid or not although it is grouped successfuly!

I did generate a new metadata with new IDs in sampleid column (first one).
I got a new error:

Plugin error from feature-table:

list index out of range

Debug info has been saved to /tmp/qiime2-q2cli-err-afsi_5l3.log

This is my new metadata id column:

A question crossed my mind. Before grouping samples, I merged two rep-seq and tables then I tried to grouping.
The Illumine sequencing center made two .gz files from my each library that I mix them (technical reason I think). I wanted to merged the two seq and tables of each libraries at first then group the samples. Later, merge other seq and table of libraries together (it is the third step). would it be the problem in visualization step after grouping?

The error was searched in forum. Many of them are related to Vesearch not metadata file.

I did all I could.


This thread helped me out! Thanks @Marcus Fedarko

But I have a question regarding grouped-table summery. I will open a new topic in this regard.

Sorry, I made the thread longer in monologue! I just wanted to report my errors step by step.


1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.