(1/1) Missing option '--m-metadata-file'. in qiime feature-classifier classify-samples

It is run in conda. My full code is this: qiime sample-classifier classify-samples --i-table 702260_merged_table.qza --output-dir 702280_ml_trial --m-metadata-file merged_metadata.tsv --verbose

I>'m pretty sure I entered that option. Why does it happen? Thanks!

Hello @Acelya_Dalgic. The error message it gave you is incorrect due to a known bug in versions of QIIME 2 pre 2024.2. The command you ran requires both --m-metadata-file and --m-metadata-column. The real error is that you only gave it a metadata file but also needed to give it a metadata column, so the error should say Missing option --m-metadata-column.

What version of QIIME 2 are you using? This issue with the error being incorrect should be fixed in QIIME 2024.2 and on.

2 Likes

When I give --m-metadata-column 'columnname' or columnname or column index, it says categorical name is expected but numeric is received which isn't true at all.
Other than that, I don't use the newest version. Some of my old scripts didn't seem to work in the newest version so I haven't switched. I'll try it with the newest version, thanks a lot!

Can you paste the exact command you're running here along with the error? Can you also either post your metadata here or dm it to me? Thank you.

1 Like

i understood the error. i guess it needs strings as rows. for regress-samples it's 0 and 1. my initial metadata was 0 and 1 so i didn't get why it wasn't categorical. thank you!

1 Like