Y-axis offset in 'accuracy.qzv"

Hi,

I have generated a random forest predictive model using "qiime sample-classifier classify-samples".

The model works very well at predicting, but usually the "accuracy.qzv" shows a nice 'confusion matrix'-like plot. But the squares are stretched out vertically. I think it it because the y-axis is set at at '0' and 'Max', but would require a 0.5 offset to look square.

I have found a way to replicate the plot (but in Excell).

If anybody has a fix for this, would be much appreciated!

Thanks, -JA

Hi @Jeremie_Auger

Yes, this has been fixed in the most recent release (and since 2019.10) — specifically, it is a bug in an older version of matpotlib (the graphics package used to generate this plot) and can either be fixed by installing the latest version of QIIME 2 (which ships with the correct matplotlib version) or by upgrading matplotlib.

1 Like

Thank you for the fast reply. I am using a computing cluster server and… can only use the ‘module’ for qiime because the conda install doesn’t work (and I am stuck with q2019.7).
And on my laptop, qiime doesn’t like tables (and other artefacts) from other versions! (Do you think I can import my table.qza to a new version of qiime? With a command like ‘qiime import’)

But in any case thanks for the answer!
Best regards, -JA

QIIME 2 artifacts are backwards compatible, and should be forward compatible unless if you have an ancient version of QIIME 2 installed on your laptop. So this should work — maybe install the latest version on your laptop and you should be okay.

Good luck!

Hi! I figured out how to import. Had to unzip the ‘table.qza’ to get the ‘.biom’ file.
Tried the command:

(qiime2-2019.10) [email protected]_64-apple-darwin13 qiime-local % 
qiime tools import \
  --type FeatureTable[Frequency] \
  --input-path table.qza \
  --output-path 10_table.qza

There was a problem importing table.qza:

  table.qza is not a(n) BIOMV210Format file

Anyways, it ended up working, thanks! Didn’t have to re-import and re-cluster ASVs.

Have a great one, -JA

Just as a note for future readers of this thread - exporting and re-importing is not necessary.

1 Like

It is not the first time I tried importing from versions to versions and never could import the ‘table.qza’ as is. I Thought of unzipping and getting the “feature-table.biom” today and it is the only way I could transfer the table. The command to import as I previously posted doesn’t work in my experience (the command expects a biom file)
But I have to agree that the whole “importing the table artefact from previous version of qiime” is not relevant to make the “sample-classifier” module.
In any case, thanks a lot!