where to find debug info

hi everyone, I am new to qiime2.
When I ran DADA2 today with the practice in qiime2.org(https://docs.qiime2.org/2019.7/tutorials/atacama-soils/), I met a error, and it says: An error was encounted whild while running DADA2 in R (return code 1), please inspect stdout and stderr to learn more. Debug info has been saved to /tmp/qiime2-q2cli-err-z1sd4cat.log.
I want to see the info but I can’t find it in my file and also can’t find it with search tool. I am really confused, does anyone can help me?

Good morning Mavis,

In the same terminal that you used to run the command, type this:
head /tmp/qiime2-q2cli-err-z1sd4cat.log

That should show the first few lines of that file, which is located inside of /tmp/ instead of a more common location like Documents or Downloads.

Let me know if that works for you. Often times the error is also printed in the terminal, so instead of opening the file, you can also just scroll up and look for the error there.

Colin

2 Likes

@Mavis run all of your commands with the --verbose flag added to the command, and any error messages will print to the terminal instead of appearing in the log file.

1 Like

Thank you very much for you reply!
I just added the code before the --o-representative-sequences, and the --verbose code works well !

Because of your help, I know how to see the bug info (Although I haven’t known how to deal with the bug, I feel happy because I can know what’s wrong with my code !)

Thank you again!

Mavis

Thank you very much for your answer! And I try the head code, it works well !


The reason why the log’s name is different is because I lost the result I got yesterday and ran these code again. the “head” code can show me several lines of log successfully!

What’s more, someone told me that I can use “less” code to see the whole log, I tried it and found it also makes sense. My code is less /tmp/qiime2-q2cli-err-3jkcrrab.log . After seconds, the terminal shows me the log, and when I use “q”, it is back to the main terminal.

But I didn’t see the bug info in the terminal directly. Maybe because I use the VitrualBox?

Besides, the --verbose works well, it can show me the log when the code is running.

(the picture shows the process of my code.

Thank you again for your help!

Progress! :trophy:
And you are using head and less, two iconic linux commands. Great job.

While we might not be able to see the full error, we can see the error code (return code -9). The -9 code means that the process was “killed” (canceled) by the system. This could happen if the system runs out of memory when running the job.

Try running dada2 again with the flag --p-n-reads-learn 10000. The default here is 1.0 million reads, and I’m suggesting you use 0.01 million reads (10k reads). This is a much smaller number so it will use less memory, and hopefully keep the job from being killed with another -9 error code.

Colin

1 Like

Thank you very much for your help and suggestion! I have done it successfully, and now I knew the problem is caused by the lack of memory~:grinning:

It is so kind of you to answer my questions! Thank you again sincerely!

Best wishes!

Mavis

1 Like

Hi @Mavis - glad to see you got it working, but 100 for the n-reads-learn is very low (“Smaller numbers will result in a shorter run time but a less reliable error model.”)— I would suggest trying at 10,000, like @colinbrislawn suggested.

1 Like

Okay, I got it!:+1:

I will try it again now! Thank you again!

Best wishes~

Mavis

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.