Were you able to solve your --parttree problem?

Hello iwmtpione.

Were you able to solve your --parttree problem? I am running into the identical problem as the number of sequences in my feature table is larger than 1 million.

I have tried to run this, but received the error below.

qiime alignment mafft \

–i-sequences data_rep_seqs.qza
–p-parttree
–o-alignment aligned-rep-seqs.qza
–o-masked-alignment masked-aligned-rep-seqs.qza
–o-tree unrooted-tree.qza
–o-rooted-tree rooted-tree.qza

I have these errors:
(1/3?) no such option: --o-masked-alignment
(2/3?) no such option: --o-tree
(3/3?) no such option: --o-rooted-tree

Any suggests would be appreciated (btw, I am a new qiime2 user).

Thanks!

Hi @watson welcome to :qiime2:!

I think you mean to use one of the following phylogeny pipelines, and not qiime alignment mafft

One example:

qiime phylogeny align-to-tree-mafft-fasttree \
  --i-sequences data_rep_seqs.qza \
  --p-parttree \
  --output-dir mafft-fastree-out \

Type qiime phylogeny align-to-tree-mafft-fasttree --help to see the available parameters. I recommend reading through the q2-phylogeny tutorial. Other tutorials can be found here.

-Cheers!
-Mike

1 Like

Thank you @SoilRotifer! Your tip solved the problem and the tutorial is helpful.

Cheers,

Katie

2 Likes