Viewing visualization failed while attempting to open .qzv outputs


When I run "qiime tools view" to visualise .qzv outputs, I encounter the error of failing to show the file. Basically, I am not able to visualise any .qzv file.

  * My system: QIIME2 2023. and conda in WSL

I found a similar issue on the forum before, and someone suggested using QIIME2 View (, but when I copy the link that appears in my error into QIIME2 View, still it does not work.

I appreciate your help.

Hi @Mohamad_Eshaghi_Gorj,

Welcome to the :qiime2: forum!

Can you please provide more details regarding the error you mentioned above? What is the exact message that you receive in your command line after running qiime tools view? And what exactly happens (screenshots or full error details) when you attempt to upload your file to

Thank you lizgehret for your reply. The screenshot shows my commands and the error I received. I get this error for the visualisation of any .qzv file.
Also, when I copied the link in the error to QIIME2 View, I got no response.
Thank you.

Hi @Mohamad_Eshaghi_Gorj,

Do you mind sharing your table.qzv file? I'd like to see if I can replicate this on my end. Thanks!

Dear @lizgehret, the .qzv output is generated by my command (as shown in the above picture) is a part of QIIME2 “Moving Pictures” tutorial.
Below is the file I downloaded from the tutorial (not produced by me):
table.qzv (442.4 KB)
I can also view this file using QIIME2 View, but the problem is when I run the command and produce the same file as output, it cannot be visualised using "qiime tools view". In addition, I want to use the alternative method for visualisation of .qzv file, QIIME2 View, in which I need to access the file and then upload it in QIIME2 View, but I don't know how to download the file from my WSL.

Thank you so much for your time.

Hi @Mohamad_Eshaghi_Gorj,

Thanks for providing those details. I suspect there is an issue with your environment, as I was not able to reproduce this error on my end. A couple of follow-up questions for you:

  • Have you been able to run qiime tools view on other versions of QIIME 2 on your WSL instance?
  • Can you try re-running the command with --verbose to see if we get any additional traceback along with the error message you are receiving and share that output in your response?

Thanks! :lizard:

1 Like

Dear @lizgehret

  • I have also tested in QIIME2-2022.2 (the same command and .qzv file), but it still resulted in the same error.

  • I also re-ran the command with --verbose (as shown below).

What I do now is to copy the file into my Windows and visualise it using QIIME2 View. However, it would be better to solve this issue in the end.

Thank you so much.

Hi @Mohamad_Eshaghi_Gorj,

Do you know what type of server your WSL instance is configured with?

We have had several other forum users run into this issue while using a headless WSL instance (see forum post here for reference). I would check out the suggestions in that thread for some options that you have to resolve this, if you are in fact on a headless WSL instance.

Hope this helps! Cheers :lizard:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.