View Qiime2 Page error: taxa bar plot

I’m trying to upload my taxa bar plot into view.qiime2.org but it keeps rejecting me and giving me the “Aww, snap!” error. I’ve tried to attach it to this post but it says it’s too large (3072 KB). I’m unsure of what the exact issue is because I’m able to upload my pcoa plots to the view page. But, I assuming the issue is that the file is too large. I try to collapse to level 6 or level 2 first but it is giving me an error.

First I run

qiime taxa collapse \
> --i-table  reference-hit.qza \
> --i-taxonomy taxonomy.qza \
> --p-level 6 \
> --o-collapsed-table level-6

to collapse to level 6. But when I run

qiime taxa barplot   \
> --i-table level-6.qza   \
> --i-taxonomy taxonomy.qza  \
> --m-metadata-file merge_no_blank2.tsv   \
> --o-visualization taxa-bar-plots.qzv

Then I get this error:

Plugin error from taxa:

  unhashable type: 'Float64Index'

Debug info has been saved to /var/folders/n8/0xt_lgk564l03t70txcj45xc0000gn/T/qiime2-q2cli-err-jxpjq2jm.log

Thank you!

Hi @Stephanieorch!

Sorry for the very delayed response.

This is probably because there are too many SVG nodes in our image for the browser to handle :frowning:

That’s weird, but it is probably because it is attempting to match the feature axis of the table (which are now taxonomy strings) against feature IDs in the taxonomy (which are missing now that we have taxonomy strings instead).

One thing you could try is to use feature-table group and collapse your samples together into relevant groups. Usually I think the viz crashes because there are too many samples to draw at once (it might have trouble with too many features as well, but since it starts at level 1, you won’t see this happen until you select something like level 7).

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.