V4 region classifier trouble

Hi all, my sequence amplifying V4 region. I’m trying to change my scikit-learn version to 0.21.2 in order to use the V4 classifier (I’m using Qiime2-2020.2).

I’m using the command1: conda install --override-channels -c defaults scikit-learn=0.21.2. After running command1, I run command2: qiime feature-classifierclassify-sklearn --i-classifier silva-V4-qiime2019_10.qza --i-reads rep-seqs.qza --o-classification taxonomy.qza. However, I still get the following error.

The scikit-learn version (0.21.2) used to generate this artifact does not match thecurrent version of scikit-learn installed (0.22.1). Please retrain your classifier for your current deployment to prevent data-corruption errors.

What should I do? Please help. Thanks in advance

Hello @alexp,
Great question and I hope that I am able to help.
This person was having a similar issue. The suggestions were:

  1. you can get a new classifier that is compatible with scikit-learn 0.22.1.
  2. you can download an older version of Qiime2 that is compatible with your classifier. Nick talks about how he suggests doing that in this post. This would allow you to use the classifier you have now and switch back to Qiime2 2020.2 for downstream analysis

I hope this helps! :qiime2:
Chloe :turtle:

2 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.