uploading metadata file issue

Hi all,

I just downloaded qiime2 on Windows Subsystem for Linux. I have previously used qiime2 on docker/galaxy as shown in many of the YouTube tutorials available online. I am attempting to go through the Moving Pictures Tutorial, but using my own files to familiarize myself with this version of Qiime2 on linux. I am using the same metadata file that I had worked with previously, which worked fine with Qiime2 docker to run everything I needed in docker. I have checked the read permissions and the metadata file with keemei - both of which should not be an issue. I have checked the forum for issues similar to this and it seems as though most other issues users have run into have been due to path errors, so I am assuming that is the same issue that I have. However, I directly copied the path from the file on my computer. When I copied the file path from my computer it reads "C:\Users\NGreenberg\Documents\FMT Sequencing Files\ubuntu test stuff\FMT-metadata - Sheet1.tsv". I have attached a screenshot of the issue to this post.

Any and all advice would be greatly appreciated.

Thank you,
Nathan Greenberg

Hello Nathan,

I think you are on the right path and asking all the right questions.

In your WSL terminal, run this command:
explorer.exe .

That will open up a Windows Explorer window at the target path of ., which is your current directory in Linux. Then copy your metadata file into that new Explorer window.

(When using WSL, I find it easier to move my Windows files into the WSL file system, which is what I'm suggesting here. While you could access C:\Users\whatever from Linux, I find this way easier.)

1 Like

Hi Colin,

Thank you very much for your reply. I tried running:
explorer.exe .

I tried running this command in both my WSL terminal and in my ubuntu terminal.

When running in WSL this opened "C:\Windows\System32..." path. I pasted in my metadata and the path reads "C:\Windows\System32\Metadata_FMT.txt". I tried running the metadata tabulate command using this data and received the same error as before (screenshots attached).

When running in Ubuntu this path opened: "\wsl.localhost\Ubuntu-22.04\home\nagr4657". I pasted in my metadata and the path reads "\wsl.localhost\Ubuntu-22.04\home\nagr4657\Metadata_FMT.txt". I tried running the metadata tabulate command using this data and received the same error as before (screenshots attached).

Any ideas why this might be happening or do you have another file upload strategy that might work better?


It looks like you are still inside your Windows paths, not the Linux-y paths of WSL.

You can run cd ~ to return to your home directory, then open that using explorer.exe . in WSL and try moving files there. (My guess is that Qiime2 does not like the Windows-y paths from your host OS and I'm hoping sticking to the Linux paths of the WSL home directory will solve this problem.)

Just to check, are you running WSL locally on a Windows machine, or on a remote server / cloud machine?

Hi Colin,

Thanks again for responding. I am running WSL/Ubnutu locally on my windows laptop. I am running the qiime 2 metadata tabulate command in Ubuntu not WSL. I tried following the instructions you provided.

Restarted computer and opened Ubuntu. Ran explorer.exe .

This window opened. I had opened the same window previously and pasted my metadata (highlighted).

I opened / activated Qiime2, and tried to run metadata tabulate:

Since this didn't work I tried from WSL: I typed cd and ran explorer.exe .

This opened this folder and I pasted in my metadata.

I went back to ubuntu and tried to run the metadata tabulate using this path:

Perhaps I am doing something wrong in the initial just opening/setting up of the qiime2 that is limiting my ability to use my files?


1 Like

Thank you for all these details, Nathan. That's super helpful!

Here's what I noticed:

Your input file paths are 'Windows-flavored' because they use \backslashes\ to separate folders.

Linux paths use /forward/slashes/.

(I'm guessing the Windows paths are confusing these Linux terminals. I don't know enough about Linux-on-Windows to fix the absolute paths, so using relative paths is my workaround.)

For the input, try running using a relative path without any slashes at all, like
--m-input-file Metadata_Effects_...
with the full file name of your metadata.

You will know this works if you type
--m-input-file Meta
then press the Tab key and the rest of the file name appears.

1 Like

Hi Colin,

This worked! Thank you very much for your help with this issue!!!


1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.