Update scikit-bio dependency to 0.5.2 or newer

How would one go about pushing the QIIME2 ecosystem to depend on a newer version of scikit-bio? As of 2018.6 the dependency is pinned to 0.5.1, however I would like to try and make a push so that 2018.8 depends on 0.5.2 (possibly 0.5.3 - depends on additional development). This way a couple of additional plugins can be added to QIIME2, namely permdisp and perhaps PCoA biplots.


Hey @yoshiki,

At the moment, the specific version used is at the mercy of conda’s dependency resolution. To bump the version, it requires all packages to agree on at least a minimum otherwise we end up with a conflict (which is fine since at least we can address it).

For scikit-bio, I would recommend setting the minimum in q2-types which every other plugin depends on. Ideally this won’t cause a problem with anything else, but who knows.

Semi-related, for skbio, do we still fix the numpy version? QIIME 2 is pretty far behind on that, and I’ve suspected it was skbio, but I haven’t really checked that yet. @thermokarst and I had discussed trying to sprint on the skbio dependencies and bringing them back up to date, but it hasn’t really panned out yet.


That’s a great suggestion, I’ll give that a shot for 0.5.2 to test the waters and see what happens.

Numpy is still fixed in scikit-bio (< 1.14). Numpy is currently in development for the 1.15.x series, so it is not dramatically out of date.

I would be game to help bring those dependencies up to date, as well as fixing the unit tests. The MSA object’s tests seem to keep breaking ¯\_(ツ)_/¯. Currently there’s a few test failures in the skbio build. Let me know how to help.