Unexpected Error during Import [PairedEndFastqManifest]

Hello, I have been trying to import my sequence data through the PairedEndFastqManifestPhred33V2 protocols, but have been getting this error code in red when I try to import by manifest file - "An unexpected error has occurred:
Unknown expression: <class '_ast.List'>" and some more debug info. This error seems to be unrelated to my data set, but I am stuck on how to fix it. I am a beginner to this software so any suggestions appreciated.

Hi @Hayley_Guay!

Sorry to hear you're running into problems, but unfortunately we are missing quite a bit of important information necessary to help you! Please provide the following:

  • The version of QIIME used
  • The exact command or commands run (copy-and-paste)
  • The complete error observed

Thanks! :qiime2:

This is a screenshot showing the exact command I entered and the entire response it gave. Please let me know if you need to see anything more. I am using qiime2 (2021.4) Thanks!


I have been trying different methods to import my files but no such luck yet - it seems like Ubuntu(qiime2) is not able to access to files on my local disk in order to import. Is there any way to check if I have missed a step importing? I am following the protocol that I completed the tutorials with, adjusted for my dataset. The screenshot shows the command and error I have been getting.

Anyone have any ideas? Running this on a windows computer, still qiime2-2021.4

1 Like

Hi @Hayley_Guay!

Looks like you've got a few issues here!

The issue here is that you have a typo in the --type parameter - you specified [PairedEndSequencesWithQuality] when you probably meant SampleData[PairedEndSequencesWithQuality]

There is an issue with the --type here, too - you have specified an invalid type for the particular --input-format you're using here - you can update this to SampleData[SequencesWithQuality]. Please see this tutorial for more details.

Finally, there is a third issue - it will become a problem once you sort out the --type issues above --- you appear to be providing a windows-style filepath to your --input-path flag, however the rest of the paths in the logs above show unix-style filepaths - you should be using the unix-style paths. If you're using the WSL, then you'll need to make sure you're providing the appropriate path to the drive with your files, too.

Keep us posted!
:qiime2: :t_rex:

Thank you, this helps! Is there any way to get the unix style filepaths from the windows file? I used the wslpath command to change my manifest filepath within ubuntu, but the manifest is still full of windows style paths that the program does not want to read.

Edit - I did also notice that I was using the wrong file type (or at least, mislabeling my data as the wrong type). I am trying to input a FastQ manifest file that contains separate filepaths to the forward and the reverse reads of each sample (10 samples in total, one forward and one reverse read for each, separate files for the fwd/rev reads). I've included the new command and the error it now gives me.

Glad to hear it!

I'm not sure, I don't use the WSL, its a little bit outside of our wheelhouse at Q2-HQ. Maybe you can write a script? Or use find-and-replace in a text editor?

This is the same problem as before - your --type doesn't match the --input-format you've specified - take a look at the tutorial I shared in my last post, it has two examples for the SE and PE versions of the manifest formats which should help you get on the right path!


An off-topic reply has been split into a new topic: Types vs Formats - Phred Offset

Please keep replies on-topic in the future.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.