Unable to import data in moving pictures tutorial

Hello all,
I am facing a similar problem when importing single end sequences in the moving pictures tutorial. I followed the following query and was successful to some extent. However, I am getting a different error now. I am attaching a pic of the code for more information. Can anyone provide any solutions? I am unable to import the data even if I created a desktop file named "Emp-Single-End-Sequences" and downloaded and extracted all the files related to the tutorial. I think I am missing something.
qiime|690x240

I was able to find a partial solution for my problem here

Thank you

Sincerely
Rocktim

Hi @RocktimRamenDas, I have made this request public - we do not provide private support on this forum.

Can you please fix your post up? The following items are missing:

  • This link is broken:
  • Your attachment didn’t get attached

Thanks!

2 Likes

Thank you @thermokarst I updated the question.

Good evening @RocktimRamenDas,

Thanks for updating your question!

This is one of those problems that’s hard to spot because your file locations are almost perfect, but not quite 100% perfect. Hopefully we can get this fixed.

Based on your post, I think your files are set up like this:

folder you are in: emp-single-end-sequences
(file) 'Moving Pictures sample-metadata Qiime 2 2019.10 - sample-metadata.tsv'
(file) barcodes.fastq
(folder) emp-single-end-sequences
(file) sequences.fastq

The files are green and the folders are blue.

… Wait, it looks like you have two emp-single-end-sequences folders.

~/Desktop/emp-single-end-sequences/
~/Desktop/emp-single-end-sequences/emp-single-end-sequences

Once you remove that extra folder, then run the qiime tools import from the Desktop folder, this command should work!

Let me know if that solves the mystery! :female_detective: :mag:

Colin

1 Like

Thanks @colinbrislawn for the reply. I tried as per you said.
I got this error.

Photo Attached.

Hmmm.. ..

OK.

My guess here is that qiime can’t find the folder… because you are in the folder when you run the command.

So use cd .. to go to the parent folder (Desktop), then run the command again.

Colin

1 Like

Hello @colinbrislawn
Seems a new error. I think I am missing something here.

Rocktim

Hi @RocktimRamenDas!

I have a strong suspicion that if you start over fresh (delete everything you have done so far) and follow the directions exactly, you will be fine. One thing I like to remember is that computers aren’t clever or smart - they don’t “fill in the blanks” when you make a mistake, they will just do whatever you told them to do, until it doesn’t work anymore. I think that might be what happened here - one little mistake on your part when you first started has cascaded into a handful of confusing errors.

Please carefully review the documentation and follow each step precisely (countless people have preceded you on these steps, you can rest assured that it does work as advertised).

Keep us posted!

2 Likes

I think @thermokarst's advice is sound: the moving pictures tutorial should run like a cooking show. But, here's my theory:

In your folder, you have barcodes.fastq and sequences.fastq, but in your command, the error message is looking for sequences.fastq.gz. You've gunzipped your sequences somewhere along the way, and that's why this isn't working.

Best,
Justine

3 Likes

Thank you @jwdebelius @colinbrislawn @thermokarst it worked. Actually I unzipped the file. I removed both the unzipped file and the raw tsv file. And only kept the two sequence.fastq.gz and barcode.fastq.gz zipped file in the emp-single-end-sequences folder in Desktop. Once I ran the command it worked seamlessly.

Attached Picture

Cheers
Rocktim

3 Likes

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.