UInrecognized file for EMPSingleEndDirFmt

Hello! , when i ran the code ( from the moving pictures tutorial)
qiime tools import
--type EMPSingleEndSequences
--input-path emp-single-end-sequences
--output-path emp-single-end-sequences.qza

This mesage appears
There was a problem importing emp-single-end-sequences:
Unrecognized file (emp-single-end-sequences/sequences.fastq) for EMPSingleEndDirFmt.

Hi @eli0113,

Welcome to the :qiime2: forum!

It looks like you're getting an error message for the import. Can you please double check the contents of your emp-single-end-sequences directory and share the output?

I suspect that there's an issue with the file format. (What's different between this file and the one in the original tutorial?)

Best,
Justine

Thanks for your answer
when i use the wget command to get the files, they are "sequences.fastq.gz" and "barcodes.fastq.gz" (both type ALZip GZ file) and then i uncompressed through the terminal (gzip -d command) and they become "sequences.fastq" and "barcodes.fastq". I have all the four files (2 ALZIp GZ File and 2 FASTQ File) in the "emp-single-end=sequences" directory.

When I ran the code in my laptop through a virtual box it works but when i do it through the computer in my workplace i have the problem above. When i use wget to get the files it appears me this message

ERROR: cannot verify data.qiime2.org's certificate, issued by ‘/C=GB/ST=Greater Manchester/L=Salford/O=Sectigo Limited/CN=Sectigo RSA Domain Validation Secure Server CA’:
Unable to locally verify the issuer's authority.
To connect to data.qiime2.org insecurely, use `--no-check-certificate'

However, I apparently solve it when i use the command wget --no-check-certificate

Maybe that is the root of the problem of the importing?.

Hello! I found where the problem was!
The computer of my workplace was using a not updated version of qiime so therefore the importing command and wget command did not work properly. I updated the version of quiime and everything now works :slight_smile:

1 Like

Hi @eli0113,

I'm glad you were able to solve it with a version update! The issue I was thinking of was that your files were not gzipped anymore so the algorithm couldn't find them. But, I'm glad you discovered/solved the problem yourself!

Best,
Justine

1 Like