Two different primers in my Ion torrent sequence file


(Manoj Kumar) #1


I have a fastq sequence file (have both multiplexed and demultiplexed files) from ion torrent.In total there are 192 samples in the sequence with 2 barcodes (16s and ITS). 96 samples with 16s primer and 96 samples with ITS primers and both the 16s and ITS primers are attached to the same barcodes. I find it difficult in Qiime 2 to import or analyse the data. In Qiime1 I can just change the primer sequence in mapping file and either 16s or ITS primers get excluded. Is there a simiar method to do this in Qiime2 as well?

Is it possible to separate the sequence file based on primers and do the downstream analysis. I have been trying different methods but couldn’t able to figure out.

Kindly advise how to proceed with my sequence data.

(Nicholas Bokulich) #2

This should not be an issue to import, and should cause minor issues with processing.

Since 16S and ITS are quite dissimilar, you can use alignment-based filtering to remove these. Two options:

  1. deblur performs positive filtering as part of the pipeline (i.e., it removes sequences that do not roughly resemble the reference database). This will NOT work for you, however, as I believe deblur is not appropriate for Ion Torrent data.
  2. You can use qiime quality-control exclude-seqs to perform this same type of filtering. This would occur after denoising/OTU clustering.

So in your case, use dada2 denoise-pyro to denoise (or use OTU clustering if you prefer), then use exclude-seqs to separate out 16S and ITS sequences.

(Manoj Kumar) #3

Thank you, I will try this.

(Manoj Kumar) #4


I did the exclude-seqs step after denoising my sequences. If I am not wrong I should use the rep-seqs.fasta file I got as an output from the denoising step as an input here. If that is so, I understand that I will get the new file from the exclude.seqs with 16s and ITS sequences. But how do I get the OTU table for my 16s and ITS sequences? I understand that there is one OTU table output from the denoise-single.

I used following commands to separate the 16s and ITS sequences

qiime dada2 denoise-single
–i-demultiplexed-seqs Run1_trimmed16s.qza
–p-trim-left 13
–p-trunc-len 200
–p-chimera-method consensus
–p-n-threads 0
–o-representative-sequences rep_seqs_Run1.qza
–o-table table_Run1.qza
–output-dir Denoise

#Excluding/separating 16s and ITS sequences
qiime quality-control exclude-seqs
–i-query-sequences rep_seqs_Run1.qza
–i-reference-sequences RDP_16s_sequences.fasta
–p-method vsearch
–o-sequence-hits seqs_16s.qza
–o-sequence-misses seqs_ITS.qza
–output-dir Exclude_seqs

Kindly advise.


(Nicholas Bokulich) #5

denoise-single also outputs a sequence artifact. Looks like it will be in the Denoise directory that you generated.

(Manoj Kumar) #6

Is it possible to do this in qiime1 and the import the data to qiime2?

(Manoj Kumar) #7

I only got one output file in the denoise folder, that is denoising_stats.qza

(Nicholas Bokulich) #8

never mind, your table is table_Run1.qza1

No. qiime1 has no denoising methods.

(Manoj Kumar) #9

Not to denoise, just to separate the sequences based on primers (as 16s and ITS). I tried running, but it didn’t work since the command doesn’t recognise the forward primers. As my data is single-end reads I am unable to use the reverse primer truncate_remove option. If I do that, I lose lot of sequences.

(Nicholas Bokulich) #10

I think not — but you will need to ask on the qiime1 forum for more info.

(Manoj Kumar) #11


if I have to do that in Qiime2 and coming back to my problem, which sequence output file I should use as an output for exclude -seqs command? I only get one output sequence file from denoise-single command. That is rep_seqs.qza file. In the denoise folder I only get some stat file.

(Nicholas Bokulich) #12

Your exclude-seqs command is correct.

I think I finally understand what you are asking. You need to filter your feature table to include only the features that pass exclude-seqs (to get an ITS-only and 16S-only feature table). To do this, use qiime feature-table filter-features, using the correct sequence files as metadata inputs to that command.

Good luck!

(system) closed #13

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.