Troubleshooting filter_samples command: 'Error: no such option: --m-sample-metadata-file'

Hi all,

I've been trouble-shooting an error, but haven't yet found a fix that works(or what the user error may be) on the forum. Any guidance would be much appreciated!

error: "Error: no such option: --m-sample-metadata-file"

This is the command format I used:
qiime feature-table filter-samples --i-table rarefied_table.qza --m-sample-metadata-file antmap_spdl.tsv --p-where "species='Linepithema_humile' AND day='0'" --o-filtered-table filtered-table-FC-0

This is the format of the mapping file:

Hi @Amanda_Hale,

The error is saying that there is no parameter as --m-sample-metadata-file which is what you are describing in your command. The correct parameter name in fact is --m-metadata-file instead. Just switch those and you should be good! If you ever need a refresher regarding the commands simply use the --help tag, for example qiime feature-table filter-samples --help will give you the list of all the options for that command.

Hi! Thanks for your answer! I'm now getting .qza files with no data (empty biom file), could it be how I formatted my mapping file?

qiime feature-table filter-samples --i-table rarefied_table.qza --m-metadata-file antmap_species_day_6_8_18.txt --p-where "species='linepithema_humile'" --o-filtered-table lhDay0tabletry7.qza

Thanks again

Hi @Amanda_Hale,

It looks as though the column name of your interest is Species with a capital S, whereas your command is saying species. Also make sure you’re using the backticks around your species name instead of single quotation. They are hard to differentiate sometimes but I’m guessing the single quote will also throw out an error.

backtick = `

single-quote = '

Between those 2 corrections I think you should be good to go!


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.