trouble installing qiime2 2022.2

Dear @lizgehret ,
I am trying to install an older version of qiime2 (2022.2), we haven't published the study and I did the analysis using the version 2022.2. I have M3 pro chip, and had no problem with installing the latest version of qiime2. I followed your recommendation however could not manage. Please find below the code I used in my terminal and the responds. "Examining conflict" part takes so long.
I appreciate your help.
.....
% CONDA_SUBDIR=osx-64 conda env create -n qiime2-2022.2 --solver=classic --file qiime2-2022.2-py38-osx-conda.yml
Collecting package metadata (repodata.json): done
Solving environment: -
Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.
Examining conflict for graphite2 cctools_osx-64 perl-json-xs sortmerna ld64_osx-Examining conflict for notebook widgetsnbextension terminado: : 412it [38:45, 1Examining conflict for nbconvert-core pandocfilters nbconvert-pandoc notebook nbExamining conflict for nbconvert-core pandocfilters nbconvert-pandoc notebook nbExamining conflict for q2-gneiss gneiss: : 414it [38:46, 3.02it/s] Examining conflict for q2-feature-table statsmodels gneiss seaborn q2-demux q2-quality-control q2-sample-classifier q2-gneiss q2-diversity q2-longitudinal: : 41Examining conflict for q2-feature-table statsmodels gneiss seaborn q2-demux q2-quality-control q2-sample-classifier q2-gneiss q2-diversity q2-longitudinal patsyExamining conflict for q2-feature-table statsmodels gneiss seaborn q2-demux q2-quality-control q2-sample-classifier q2-gneiss q2-diversity q2-longitudinal patsyExamining conflict for seaborn-base nbformat gneiss scikit-bio seaborn q2-longitudinal: : 418it [38:59, 1.21s/it] Examining conflict for seaborn-base nbformat gneiss scikit-bio seaborn q2-longitExamining conflict for seaborn-base q2-feature-table gneiss seaborn q2-demux q2-quality-control q2-sample-classifier q2-gneiss q2-diversity q2-longitudinal: : 4Examining conflict for seaborn-base q2-feature-table gneiss seaborn q2-demux q2-quality-control q2-sample-classifier q2-gneiss q2-diversity q2-longitudinal: : 4Examining conflict for seaborn-base q2-gneiss scikit-bio gneiss: : 420it [39:09, 2.86s/it] Examining conflict for seaborn-base q2-gneiss scikit-bio gneiss: : 421it [39:09,Examining conflict for seaborn-base wcwidth prompt-toolkit gneiss scikit-bio seaborn beautifulsoup4 q2-longitudinal backports.functools_lru_cache: : 421it [39:1Examining conflict for seaborn-base wcwidth prompt-toolkit gneiss scikit-bio seaborn beautifulsoup4 q2-longitudinal backports.functools_lru_cache: : 422it [39:1Examining conflict for seaborn-base gneiss scikit-bio seaborn q2-longitudinal: : 422it [39:18, 3.66s/it] Examining conflict fofailed |
Solving environment: \
Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.
Examining conflict for colorama executing pyzmq tzlocal tornado pip ipython_genutils nose pygments attrs tinycss2 / a .......

Hello @sln, can you run conda update conda then conda --version and make sure you have conda 24.3.0 after updating? Then can you try to create the environment again? I was able to create a QIIME 2 2022.2 environment using the latest version of conda and the following command, but I am on Linux

conda env create -n qiime2-2022.2 --file qiime2-2022.2-py38-linux-conda.yml --solver classic

1 Like

Hello @Oddant1,
I ahde updated and checked the version and it is 24.3.0.
I am also run the conda info --envs commend:

Blockquote

conda environments:

base * /opt/miniconda3
qiime2-amplicon-2024.2 /opt/miniconda3/envs/qiime2-amplicon-2024.2"

Additionally, My conda info is as follows:
conda info

 active environment : base
active env location : /opt/miniconda3
        shell level : 1
   user config file : /Users/selinkucukavsar/.condarc

populated config files :
conda version : 24.3.0
conda-build version : not installed
python version : 3.12.1.final.0
solver : libmamba (default)
virtual packages : __archspec=1=m1
__conda=24.3.0=0
__osx=10.16=0
__unix=0=0
base environment : /opt/miniconda3 (writable)
conda av data dir : /opt/miniconda3/etc/conda
conda av metadata url : None
channel URLs : main/osx-64
main/noarch
r/osx-64
r/noarch
package cache : /opt/miniconda3/pkgs
/Users/selinkucukavsar/.conda/pkgs
envs directories : /opt/miniconda3/envs
/Users/selinkucukavsar/.conda/envs
platform : osx-64
user-agent : conda/24.3.0 requests/2.31.0 CPython/3.12.1 Darwin/23.4.0 OSX/10.16 solver/libmamba conda-libmamba-solver/23.12.0 libmambapy/1.5.3
UID:GID : 501:20
netrc file : None
offline mode : False

Tried to install 2022.2 version using two commend.
% conda env create -n qiime2-2022.2 --file qiime2-2022.2-py38-linux-conda.yml --solver classic
% CONDA_SUBDIR=osx-64 conda env create -n qiime2-2022.2 --file qiime2-2022.2-py38-osx-conda.yml --solver=classic

Still getting "Found conflicts! Looking for incompatible packages." message.

Sorry for my long massage, and thank you for your feedback.

Can you try running the command without --solver classic? We are still very much expecting it to fail, but it will most likely fail and actually give a report on what the issue was with the new solver. This might help us diagnose what's going on.

Hello @Oddant1,
Below is the resulting error.

% CONDA_SUBDIR=osx-64 conda env create -n qiime2-2022.2 --file qiime2-2022.2-py38-osx-conda.yml
Retrieving notices: ...working... done
Channels:

  • qiime2/label/r2022.2
  • 2022.2-core-passed
  • conda-forge
  • bioconda
  • defaults
    Platform: osx-64
    Collecting package metadata (repodata.json): done
    Solving environment: failed
    Channels:
  • qiime2/label/r2022.2
  • 2022.2-core-passed
  • conda-forge
  • bioconda
  • defaults
    Platform: osx-64
    Collecting package metadata (repodata.json): done
    Solving environment: failed

LibMambaUnsatisfiableError: Encountered problems while solving:

  • package cryptography-37.0.1-py310hf6deb26_0 requires openssl <1.1.2a, but none of the providers can be installed
  • package numpy-1.18.1-py36h0c13f30_0 requires libgfortran >=3.0.1,<4.0.0.a0, but none of the providers can be installed

Could not solve for environment specs
The following packages are incompatible
├─ cryptography 37.0.1** is installable and it requires
│ └─ openssl <1.1.2a , which can be installed;
├─ libcxx 14.0.4** is requested and can be installed;
├─ libffi 3.4.2** is requested and can be installed;
├─ libgfortran 5.0.0** is installable with the potential options
│ ├─ libgfortran 5.0.0, which can be installed;
│ └─ libgfortran 5.0.0 would require
│ └─ libgfortran5 with the potential options
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 *_14, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 *_15, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 *_16, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 *_17, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 *_18, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 *_19, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 *_20, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 *_21, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 _22, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 _23, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 _12, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 _13, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 3, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 _10, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 _11, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 4, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 5, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 6, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 _7, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 _8, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 9.3.0 would require
│ │ └─ libgfortran 5.0.0 _9, which conflicts with any installable versions previously reported;
│ ├─ libgfortran5 [10.4.0|11.3.0|9.5.0] would require
│ │ └─ libgfortran 5.0.0 _24, which can be installed;
│ ├─ libgfortran5 [10.4.0|11.3.0|9.5.0] would require
│ │ └─ libgfortran 5.0.0 _25, which can be installed;
│ ├─ libgfortran5 [10.4.0|11.2.0|11.3.0|9.5.0] would require
│ │ └─ libgfortran 5.0.0 _26, which can be installed;
│ ├─ libgfortran5 [10.4.0|11.3.0|9.5.0] would require
│ │ └─ libgfortran 5.0.0 _27, which can be installed;
│ ├─ libgfortran5 [10.4.0|11.3.0|9.5.0] would require
│ │ └─ libgfortran 5.0.0 _28, which can be installed;
│ ├─ libgfortran5 [11.3.0|12.2.0] would require
│ │ └─ libgfortran 5.0.0 _29, which can be installed;
│ ├─ libgfortran5 [11.3.0|12.2.0] would require
│ │ └─ libgfortran 5.0.0 _30, which can be installed;
│ ├─ libgfortran5 [11.3.0|12.2.0] would require
│ │ └─ libgfortran 5.0.0 _31, which can be installed;
│ ├─ libgfortran5 [11.3.0|12.2.0] would require
│ │ └─ libgfortran 5.0.0 _32, which can be installed;
│ ├─ libgfortran5 [11.4.0|12.3.0] would require
│ │ └─ libgfortran 5.0.0 0, which can be installed;
│ ├─ libgfortran5 11.4.0 would require
│ │ └─ libgfortran 5.0.0 11_4_0
1, which can be installed;
│ ├─ libgfortran5 12.3.0 would require
│ │ └─ libgfortran 5.0.0 12_3_0
1, which can be installed;
│ ├─ libgfortran5 12.3.0 would require
│ │ └─ libgfortran 5.0.0 12_3_0
2, which can be installed;
│ ├─ libgfortran5 12.3.0 would require
│ │ └─ libgfortran 5.0.0 12_3_0
3, which can be installed;
│ ├─ libgfortran5 13.2.0 would require
│ │ └─ libgfortran 5.0.0 13_2_0
1, which can be installed;
│ ├─ libgfortran5 13.2.0 would require
│ │ └─ libgfortran 5.0.0 13_2_0
2, which can be installed;
│ └─ libgfortran5 13.2.0 would require
│ └─ libgfortran 5.0.0 13_2_0
_3, which can be installed;
├─ libgfortran5 9.3.0
, which cannot be installed (as previously explained);
├─ llvm-openmp 14.0.4
is requested and can be installed;
├─ numba 0.53.1
is installable with the potential options
│ ├─ numba 0.53.1 would require
│ │ └─ numpy >=1.17.5,<1.21.0a0 with the potential options
│ │ ├─ numpy [1.17.5|1.18.1|...|1.19.4], which can be installed;
│ │ ├─ numpy [1.18.1|1.18.4|...|1.19.4] would require
│ │ │ ├─ pypy3.6 [>=7.3.1 |>=7.3.2 ] but there are no viable options
│ │ │ │ ├─ pypy3.6 [7.3.0|7.3.1|7.3.2] would require
│ │ │ │ │ └─ libffi >=3.2.1,<3.3.0a0 , which conflicts with any installable versions previously reported;
│ │ │ │ └─ pypy3.6 7.3.3 would require
│ │ │ │ └─ libffi >=3.3,<3.4.0a0 , which conflicts with any installable versions previously reported;
│ │ │ └─ python_abi 3.6 _pypy36_pp73, which requires
│ │ │ └─ pypy3.6 7.3.
, which cannot be installed (as previously explained);
│ │ ├─ numpy [1.19.5|1.20.0|1.20.1|1.20.2|1.20.3], which can be installed;
│ │ ├─ numpy 1.19.5 would require
│ │ │ └─ pypy3.6 >=7.3.3 , which cannot be installed (as previously explained);
│ │ ├─ numpy [1.18.1|1.18.5] would require
│ │ │ └─ libgfortran >=3.0.1,<4.0.0.a0 , which conflicts with any installable versions previously reported;
│ │ └─ numpy [1.19.5|1.20.3] would require
│ │ └─ mkl >=2023.1.0,<2024.0a0 but there are no viable options
│ │ ├─ mkl 2023.1.0 would require
│ │ │ └─ llvm-openmp >=14.0.6 , which conflicts with any installable versions previously reported;
│ │ ├─ mkl 2023.2.0 would require
│ │ │ └─ llvm-openmp >=16.0.6 , which conflicts with any installable versions previously reported;
│ │ ├─ mkl 2023.2.0 would require
│ │ │ └─ llvm-openmp >=15.0.7 , which conflicts with any installable versions previously reported;
│ │ └─ mkl 2023.1.0 would require
│ │ └─ libcxx >=14.0.6 , which conflicts with any installable versions previously reported;
│ ├─ numba 0.53.1 would require
│ │ └─ numpy >=1.19.5,<1.21.0a0 with the potential options
│ │ ├─ numpy [1.19.5|1.20.0|1.20.1|1.20.2|1.20.3], which can be installed;
│ │ ├─ numpy 1.19.5, which cannot be installed (as previously explained);
│ │ └─ numpy [1.19.5|1.20.3], which cannot be installed (as previously explained);
│ └─ numba 0.53.1 would require
│ └─ tbb [>=2019.5,<=2020.3 |>=2020.3 ] with the potential options
│ ├─ tbb [2020.3|2021.1.1|...|2021.6.0], which can be installed;
│ ├─ tbb [2021.6.0|2021.7.0|2021.8.0|2021.9.0] would require
│ │ └─ libcxx >=14.0.6 , which conflicts with any installable versions previously reported;
│ ├─ tbb [2021.10.0|2021.11.0] would require
│ │ └─ libcxx [>=15 |>=15.0.7 ], which conflicts with any installable versions previously reported;
│ ├─ tbb 2021.11.0 would require
│ │ └─ libcxx >=16.0.6 , which conflicts with any installable versions previously reported;
│ └─ tbb >=2019.5,<=2020.3 conflicts with any installable versions previously reported;
├─ numpy 1.22.4
is not installable because it conflicts with any installable versions previously reported;
├─ openssl 3.0.3
is not installable because it conflicts with any installable versions previously reported;
└─ tbb 2020.2
is not installable because it conflicts with any installable versions previously reported.

@sln it looks like your issue is primarily libgfortran.

I'm not sure why this is causing an issue for solving your environment, but can you please open the .yaml file for the environment, remove all references to libgfortran in it, then attempt to create the environment again? Your environment will still need libgfortran, but this will allow conda to more flexibly determine what version to use.

@Oddant1 Thank you for your suggestion. I removed all the references to "libgfortran" and tried it but no solution.
I run the env creation code with and without -- solver= classic option.
The resulting error is so long but I am sharing the last lines below.

  • readline=8.1 -> ncurses[version='>=6.3,<7.0a0'] -> __osx[version='>=10.9']
  • samtools=1.15.1 -> ncurses[version='>=6.3,<7.0a0'] -> __osx[version='>=10.9']
  • scikit-bio=0.5.6 -> ipython[version='>=3.2.0'] -> __linux
  • scikit-bio=0.5.6 -> ipython[version='>=3.2.0'] -> __osx[version='>=10.11|>=10.12|>=10.9']
  • scikit-bio=0.5.6 -> ipython[version='>=3.2.0'] -> __unix
  • scikit-bio=0.5.6 -> ipython[version='>=3.2.0'] -> __win
  • scikit-learn=0.24.1 -> numpy[version='>=1.19.5,<2.0a0'] -> __osx[version='>=10.9']
  • scipy=1.8.1 -> numpy[version='>=1.20.3,<2.0a0'] -> __osx[version='>=10.13|>=10.9']
  • seaborn-base=0.11.2 -> matplotlib-base[version='>=2.2'] -> __osx[version='>=10.11|>=10.12|>=10.9']
  • seaborn=0.11.2 -> numpy[version='>=1.15'] -> __osx[version='>=10.9']
  • sepp=4.3.10 -> openjdk -> __osx[version='>=10.9']
  • setuptools=59.8.0 -> pypy3.9[version='>=7.3.8'] -> __osx[version='>=10.13']
  • sqlite=3.38.5 -> ncurses[version='>=6.3,<7.0a0'] -> __osx[version='>=10.9']
  • statsmodels=0.13.2 -> numpy[version='>=1.19.5,<2.0a0'] -> __osx[version='>=10.9']
  • tapi=1100.0.11 -> ncurses[version='>=6.2,<7.0a0'] -> __osx[version='>=10.9']
  • terminado=0.15.0 -> pypy3.9[version='>=7.3.9'] -> __osx[version='>=10.13']
  • tornado=6.1 -> pypy3.9[version='>=7.3.8'] -> __osx[version='>=10.13']
  • umap-learn=0.5.3 -> numba[version='>=0.51.2'] -> __osx[version='>=10.9']
  • unicodedata2=14.0.0 -> pypy3.9[version='>=7.3.9'] -> __osx[version='>=10.13']
  • unifrac=0.20.3 -> hdf5 -> __osx[version='>=10.9']
  • urllib3=1.26.9 -> cryptography[version='>=1.3.4'] -> __osx[version='>=10.12']
  • urllib3=1.26.9 -> pysocks[version='>=1.5.6,<2.0,!=1.5.7'] -> __unix
  • urllib3=1.26.9 -> pysocks[version='>=1.5.6,<2.0,!=1.5.7'] -> __win

Your installed version is: 10.16

This last line " Your installed version is: 10.16" is telling me something probably but I have no idea :slight_smile:
I checked another conflict errors as here and it seems like I am also having a python issue but my knowledge is not enough to evaluate.

A bit above that the error is talking about versions of osx, so I think that's saying you have osx 10.16, but I'm not sure. Can you check what version you have? If you really do have 10.16 it appears as though that is quite out of date and you will probably want to update. That may have something to do with this, but I'm not sure.

Hello @Oddant1 I do not think It is about OSX version. I am already using the latest version. It is macOS Sonoma 14.4.

Unfortunately, it seems as though conda-forge (the 3rd party website that hosts many of the packages in our environments) has significantly restructured the way they serve packages for osx, and it's likely going to be extremely difficult to actually get a lot of old QIIME 2 environments to solve on osx. Your best bet if you NEED this specific release is probably going to be using a docker container.

1 Like

Thank you @Oddant1 for your help and suggestions. I will give docker a try. I was anyway willing to learn its basics.

1 Like