Trouble installing community plugin in docker on Windows

Hi @thermokarst
While I run the following:

I get the following error:

id : The term ‘id’ is not recognized as the name of a cmdlet, function, script file, or operable program. Check the
spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:27

However, when I run:

docker run -it -v C:\Users\BSen\qiime2-analysis:/data q2-its-qiime2/2018.11-with-itsxpress:latest /bin/bash

it works. So, I am just wondering, as a naive docker user, what is the purpose of id -u and id -g in your command? Thanks!

1 Like

Hey there @bsen2018!

The -u flag is for specifying the container's unix user and group. The command in the tutorial assumes that you are running on a linux-y environment (so on windows, the WSL). I have no clue how users and permissions work on windows, so I guess if it runs fine without that flag, and you can still read and write your data, well, I would call that a success! :qiime2:

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.