Trouble importing demultiplexed PE data

Hello, I am getting the same error message that was discussed here: Denoising and trimming already demultiplexed paired end data1

The error says:

Exception: No transformation from <class 'q2_types.per_sample_sequences._format.PairedEndFastqManifestPhred33'> to <class 'q2_types.per_sample_sequences._format.SingleLanePerSampleSingleEndFastqDirFmt'>

However, I have tried creating a new manifest file in excel and I still get the same error when using [SequencesWithQuality]. When I try using [PairedEndSequencesWithQuality] I get a different error saying my manifest.csv file is not formatted as a PairedEndFastqManifestPhred33 file. The first few lines of my manifest file are:

sample-id	absolute-filepath	direction
27	/data/Desktop/mv_abund/QIIME2_babypoop/fastq/27_S25_L001_R1_001.fastq.gz	forward
27	/data/Desktop/mv_abund/QIIME2_babypoop/fastq/27_S25_L001_R2_001.fastq.gz	reverse
28	/data/Desktop/mv_abund/QIIME2_babypoop/fastq/28_S26_L001_R1_001.fastq.gz	forward
28	/data/Desktop/mv_abund/QIIME2_babypoop/fastq/28_S26_L001_R2_001.fastq.gz	reverse

I am using:

qiime tools import --type 'SampleData[SequencesWithQuality]' --input-path manifest.csv --output-path paired-end-demux.qza --source-format PairedEndFastqManifestPhred33

Any feedback would be greatly appreciated.
Thank you,

Hello, I resolved the problem. I remade my manifest file and saved it as a different .csv file in excel. I also used the PairedEndFastqManifestPhred33 option which, with the new .csv file didn’t give me the “file is not formatted” error.

Thanks for sharing @cquin! Your example manifest above appears to be formatted as a TSV, instead of a CSV, which would explain the error you encountered. I suspect when you “remade” your manifest file you exported it as a CSV, which resolved the issue! Keep us posted on your analysis if you have any questions! :t_rex:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.