Trouble importing data: "manifest.tsv is not readable"

having trouble importing data. Attached is a couple screenshots of the response I get from qiime2 (2020.11) plus the format of my manifest file which I assume is the problem? Any help would be greatly appreciated!!

I had same error recently. I saved the file as manifest.txt. It worked. Also, make sure file name and extension match exactly with the script. I hope it helps.

1 Like

Thanks for the suggestion! I tried it and unfortunately, it didn't work. Could it be anything else?

Hi @chizel!

According to the screenshot, you're running this command in your home directory. Is there a file named manifest.tsv in that directory? We can check by running:

ls -lh ~/

Please run that and share the results here.

The other thing that you should be aware of (and to be clear, is not the current problem, but it will be a problem), is the filepaths inside your manifest will not work - those are Windows paths, not WSL paths.

Thank you for your reply! Sorry, I'm very new to this so I dont know what a WSL path is. Can I convert my current paths to WSL?

1 Like

WSL is an entire operating system (linux) inside of windows. I would recommend checking out for resources on learning about linux.

Thanks for the screenshot! So while you have a file called manifest.tsv in your home directory, it is not currently readable, by any of the linux user accounts in your WSL installation. How did you create this file? How did it wind up in this location?

Ok great, will do! Oh right, I created the file in Excel and saved it as a TSV, then moved it to its current location from its previous location

Great! How did you move it? Using a command? Using the GUI? Something else?

Drag and dropped the file from documents to its current location

I am using Qiime2 within WSL. File path in WSL should be /mnt/c/ e.g. /mnt/c/myrun/manifest.txt
I would also suggest creating a folder in C drive. I had problem when my files were in Dropbox. It seems you are using OneDrive. Sometimes Dropbox/Onedrive keep files in cloud. These files are not physically present on local drive. I hope it helps

Thanks @kindergarten - that is great advice, but @chizel I'll mention that the Drive Name ("C") will vary from deployment to deployment, so you'll need to tune that to your specific needs.

RE getting data into WSL, check out these Microsoft Docs:

Ok thanks guys! I will change the pathways inside the document. Is dragging and dropping the file into its current location not acceptable?

I'm not really sure what you mean by "dragging and dropping" (in the context of the WSL, I'm familiar with the notion in general) - the links I shared above are the official Microsoft docs regarding WSL filesystem actions, check those out.

Ok, will do! thanks so much for your help!


When I was setting up Qiime2(2021.11) in WSL2 in Windows 11 last month, I referred to first link posted by thermokrast. Opening explorer.exe. and dropping files there did not work for me. I do not know why. So, I created a folder on drive "h" for qiime analysis. I keep all my files there and change to that directory from command line. e.g. qiime2-2021.11xxxxxxxxx/mnt/h/run20211213 and run qiime2 from there. It has been working for me.


What if you try to write in your manifest file $PWD/processed... Instead of the full filepath? I had the same error and i solved by doing that thing, just make sure you are working in the folder (ex: if your files are in a folder called "seqs" terminal must be working within folder "seqs".

Also, the folder must have only the fast.gz files and the .tsv file, you shouldn't have another file

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.