Trimming the classifier in qiime2-2019.4.1

Hello,
I could not use the generated classifier from qiime2-2019.1 in 2019.4 as I got a message that based on my understanding, sklearn version is different from the one in qiime2-2019.4.1. So, I generated a new one. However, after trimming the reference database to the amplicon region using this code (from old version of qiime)
qiime feature-classifier extract-reads
–i-sequences ref-seqs.qza
–p-f-primer GTGYCAGCMGCCGCGGTAA
–p-r-primer GGACTACNVGGGTWTCTAAT
–o-reads silva_v132_97_515F-806R.qza

I got this message [4060:4070:0509/135248.182272:ERROR:cert_verify_proc_nss.cc(974)] CERT_PKIXVerifyCert for live.tb.ask.com failed err=-8179

I don’t know what does it mean and what should I do? I completed the downstream steps using this classifier that worked smoothly. Is there any mistake as I did not add other parameters (as in new tutorial):
-p-trunc-len 120
–p-min-length 100
–p-max-length 400 \

my primers set 515F-806R, paired reads (I believe my parameters should be different:
-p-trunc-len 245
–p-min-length 200
–p-max-length 400 \

Thanks

Hi @Eman,

I’ve seen something similar once before, I think it’s a result of running qiime tools view (which opens a browser), and then somehow backgrounding that process (ctrl-z will do that) and then continuing to use the browser. Basically you can ignore this entirely as its not coming from QIIME 2 at all, it’s just sharing the same terminal windows accidentally.

I’m not an expert on primer design, but nothing stands out as being wrong with those parameters to me (and the above message is of course completetly unreleated :slightly_smiling_face:)

Great! much thanks :grinning:

Excuse me @ebolyen, I got this message after generating representative_seq but for another set of samples using
qiime dada2 denoise-paired --i-demultiplexed-seqs demux-paired-end.qza --p-trunc-len-f 245 --p-trunc-len-r 245 --p-trim-left-f 19 --p-trim-left-r 20 --p-n-threads 3 --p-n-reads-learn 1000000 --output-dir representative_seq

[4013:4013:0509/114759.971555:ERROR:account_info_fetcher.cc(59)] OnGetTokenFailure: Invalid credentials (credentials rejected by client).
plus the total read count now changed

I also don’t understand its meaning?

however, I found the feature table excluding two samples as they don’t have any reads, at the same time, when I ran this command yesterday but using 2019.4.0, all samples have reads without any exclusion??

Thanks

This is again definitely not related to QIIME 2, so I’m as mystified as you are as to the meaning.

Which version did you run before? When you say reads do you mean the number of features in your final table? In 2019.4.0 we were able to update to DADA2 1.10 which improves quite a few things. We expect some minor shifts in the final ASV counts, so this could just be a result of that.

1 Like

I might recommend starting a new terminal (or worst case restarting) as the one you are using seems to be running quite a few things.

1 Like

I am using now 2019.4.1 the latest download. Maybe some of the samples have noise data as I repeated running codes, so what I found firstly in demux.qzv that all samples have read counts with minimum count 834 (which is low), then after running dada2 denoise I found the reads of some samples reduced dramatically, for example, one sample has zero reads. So, it may be the quality of sequences not qiime at all :grinning:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.