Training Feature Classifier issue with QIIME 2019.7

Hi Tech support,
I have been trying to do this part of QIIME pipeline and so far I have encoutered this problem today.
Can you help me out on this one?

qiime tools import
–type ‘FeatureData[Taxonomy]’
–input-format HeaderlessTSVTaxonomyFormat
–input-path 99_otu_taxonomy.txt
–output-path ref-taxonomy.qza

After running this in the terminal, the log comes like this…

Usage: qiime tools import [OPTIONS]

Import data to create a new QIIME 2 Artifact. See
for usage examples and details on the file types and associated semantic
types that can be imported.

–type TEXT The semantic type of the artifact that will be
created upon importing. Use --show-importable-types
to see what importable semantic types are available
in the current deployment. [required]
–input-path PATH Path to file or directory that should be imported.
–output-path ARTIFACT Path where output artifact should be written.
–input-format TEXT The format of the data to be imported. If not
provided, data must be in the format expected by the
semantic type provided via --type.
–show-importable-types Show the semantic types that can be supplied to
–type to import data into an artifact.
Show formats that can be supplied to --input-format
to import data into an artifact.
–help Show this message and exit.

              There were some problems with the command:

(1/2) Missing option “–input-path”.
(2/2) Missing option “–output-path”.
./ 11: ./ --input-path: not found

Hi @Imee19,

If you are copy pasting your commands like this you’ll need to add a \ at the end of each line to indicate a new line.
So, instead try:

qiime tools import \
–type ‘FeatureData[Taxonomy]’ \
–input-format HeaderlessTSVTaxonomyFormat \
–input-path 99_otu_taxonomy.txt \
–output-path ref-taxonomy.qza

Alternatively you can type the entire command in one line then you wouldn’t needed the slashes

1 Like

Hi Mehrbod,
When I ran it in the terminal, there were back ticks, may be it got erased when I copied it from the terminal. Anyway,I am still getting this comment in the log report. I am still figuring out where I made a mistake.

Hi @Imee19,
Hmm, I’m still thinking something is happening with the formatting because the error message is acting like there was an interruption mid command. Are you copy pasting your commands from text editor like Word? Sometimes characters get changes going from these into terminal which may produce unwanted characters.
If you type your commands manually by hand in terminal (without the slashes) all in one line do you still get the same error?

Can you try copy pasting the commands below? Note the -- vs between the two boxes, also using '' quotes instead of ‘’ though I don’t think this is the issue.

qiime tools import \
  --type 'FeatureData[Taxonomy]' \
  --input-format HeaderlessTSVTaxonomyFormat \
  --input-path 99_otu_taxonomy.txt \
  --output-path ref-taxonomy.qza

Also, which qiime2 version are you using?

Hi Mehrbod,
You are right, I miss a back tick so that made the error but I encountered another one under Features Classifier. I have read the post from last year,I did what was suggested but still there is an error

and it goes like this…

#Pre-training of V4-V5 classifier

Error: QIIME 2 plugin ‘feature-classifier’ has no action ‘extract-reads–i-sequences’.

The Script:

#Pre-training of V4-V5 classifier

qiime feature-classifier extract-reads\

–i-sequences 99_otus.qza\



–o-reads ref-seqs.qza

Did check the format as per listed in the forum post…

qiime tools peek 99_otus.qza

UUID: a68522ff-ab27-4bed-927d-8c0100d58050

Type: FeatureData[Sequence]

Data format: DNASequencesDirectoryFormat


missing a space. “extract-reads–i-sequences” should be “extract-reads --i-sequences”

1 Like

Thank you, I saw that it was what I missed.