Tools import PairedEndFastqManifestPhred33 is taking forever

Dear qiimers,

I am trying to import files into qiime2 format. My files are fastq files (one reverse and one forward per sample) and I created a fastq manifest following the guidelines of the “importing” tutorial.

I tried to run it on 4 files to start with and it worked pretty quickly (and I could do all the dowstream analyses no problem), and now I have extended it to my 64 files and it has been running for hours with no errors but also no output (I am using 1 node of 32 threads). I am wondering if it is normal that it is taking so long, or if I did something wrong…

Here is the command I am running:
qiime tools import --type ‘SampleData[PairedEndSequencesWithQuality]’ --input-path manifest --output-path paired-end-demux.qza --source-format PairedEndFastqManifestPhred33

Thanks in advance for your help

Hi @Estelle — this step can take a while, and unfortunately there isn’t a really great rule-of-thumb for estimating the runtime (it is a function number of samples, read counts, etc). If it is going to error, it will do so noisily, so if you haven’t seen anything yet, you should be in good shape, just keep on keepin’ on!

Keep us posted, and happy QIIMEing! :t_rex:

Hi @thermokarst,

Still running :slightly_smiling_face:
Thanks for the answer, I am going to wait, I only have the node for 12 hours…hopefully it will be enough. I noticed it is using only 1 CPU at 100%, would it be possible to use more than 1, or it is not built like that?


Hi @thermokarst,

It took 7h to complete! But it looks like it worked!
La patience est la reine des vertues.



Woohoo!!! That is great news :tada::fireworks::heart::gem:

We don’t currently support parallel demultiplexing, sorry!

Good luck and feel free to open a new thread if you have any questions or comments while exploring QIIME 2 with your freshly imported data! :t_rex:

An off-topic reply has been split into a new topic: Manifest File: Invalid text encoding

Please keep replies on-topic in the future.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.