"Tini is not running as PID 1" warning in qiime2 docker

Hello, I’m installing the qiime2 docker image but I get this warning about Tini

$ docker --version
Docker version 18.09.2, build 6247962
$ docker pull qiime2/core:2019.7
$ docker run -it --rm --init qiime2/core:2019.7 /bin/bash
[WARN  tini (6)] Tini is not running as PID 1 and isn't registered as a child subreaper.
Zombie processes will not be re-parented to Tini, so zombie reaping won't work.
To fix the problem, use the -s option or set the environment variable TINI_SUBREAPER to register Tini as a child subreaper, or run Tini as PID 1.

Shouldn’t --init solve the problem?
Is there any workaround to avoid this warning? (it’s hard for me to figure it out by myself without having the Dockerfile)

Why are you adding the --init flag?

--init actually appears to be the source of the problem:

image

Hi @thermokarst ,
I can be wrong but I used --init because from here : https://docs.docker.com/engine/reference/run/
I understand using it you can enable tini as the default docker init process, helping killing zombie processes.
See more info on tini here: https://github.com/krallin/tini

Thank you for the Dockerfile, I was thinking maybe the problem was the dockerfile used an entrypoint like this

ENTRYPOINT ["/tini", "--"]
CMD ["/your/program", "-and", "-its", "arguments"]

but it doesn’t. So I’m quite puzzled about why this happens using --init , but I suppose I can just not use it until I figure out why this happens. :slight_smile: Thank you :slight_smile:

I suspect that feature is more important for daemons and other long-running services. I would just skip it for now since you don’t have a clear need for it.