The table does not appear to be completely represented by the phylogeny.

Hi Qiime2 team!

First of all, I would like to thank the possibility to view qiime2 workshop last week. It was very good and helpful for me (2-month-old q2 user).

I have a question about an error in the plugin qiime diversity core-metrics-phylogenetic. After conducting taxonomic classification with a trained SILVA138 for V3-V4 region, I wanted to filtered out mitochondrial and chloroplast sequences. These were the commands:

$qiime taxa filter-seqs
–i-sequences rep-seqs.qza
–i-taxonomy taxonomySIL.qza
–p-exclude mitochondria,chloroplast
–o-filtered-sequences sequences-no-mitochondria-no-chloroplast.qza

$qiime feature-classifier classify-sklearn
–i-classifier silva_classifier.qza
–i-reads sequences-no-mitochondria-no-chloroplast.qza
–o-classification taxonomySIL_MC.qza \

$qiime taxa filter-table
–i-table table.qza
–i-taxonomy taxonomySIL.qza
–p-exclude mitochondria,chloroplast
–o-filtered-table table_MC.qza \

Until here there were no problem. With the new table, I could check alpha-rarefaction and phylogeny, as follows:

$qiime diversity alpha-rarefaction
–i-table table_MC.qza
–m-metadata-file metadata.tsv
–o-visualization alpha_rarefaction_curves.qzv
–p-min-depth 10
–p-max-depth 15000 \

$qiime phylogeny align-to-tree-mafft-fasttree
–i-sequences sequences_MC.qza
–o-alignment aligned-rep-seqs_MC.qza
–o-masked-alignment masked-aligned-rep-seqs_MC.qza
–o-tree unrooted-tree_MC.qza
–o-rooted-tree rooted-tree_MC.qza

The problem is in the following command:

$qiime diversity core-metrics-phylogenetic
–i-table table_MC.qza
–i-phylogeny rooted-tree_MC.qza
–m-metadata-file metadata.tsv
–p-sampling-depth 15000
–output-dir ./core-metrics-results_MC \

The error is:
Plugin error from diversity:

The table does not appear to be completely represented by the phylogeny.

Please help me qiime2 experts!

Thanks a lot!
CV

Hi @CVicent,

We’re happy that you enjoyed the online :qiime2: workshop!

Upon first glance, everything appears to be in order, except for one thing. Remember generating rarefaction-curves is not the same thing as rarefying. Setting the –p-min-depth 10 and –p-max-depth 15000 for diversity alpha-rarefaction, are for setting the min and max value for the range of sub-sampling depths that you’d like generate your rarefaction curve. That is your curves will start at 10 and end at 15000. This helps you determine how well you’ve sampled the community

The –p-sampling-depth 15000 specified in diversity core-metrics-phylogenetic will randomly sub-sample your data set once. Any samples with less than 15000 reads will be discarded. Which likely means you are removing most, if not all, of your samples. When this happens there are no longer any features in the feature-table to map to the phylogeny.

Make a visualization of your feature-table using qiime feature-table summarize.... Then click on the Interactive Sample Detail tab, and adjust the Sampling Depth slider to see how many samples / features you loose at 15000. An example of this is provided on the home page of QIIME 2 View.

Also, how did you generate the sequences_MC.qza file? I assume you ran something like this?

qiime feature-table filter-seqs \
    --i-data rep-seqs.qza \  
    --i-table table_MC.qza \
    --o-filtered-data sequences_MC.qza

That is, you use your filtered feature-table, table_MC.qza, to keep the corresponding sequences from rep-seqs.qza, to make sequences_MC.qza.

-Mike

2 Likes

Amazing @SoilRotifer! My problem was the last command. It run smoothly. Thank you very much! I misused the plugin qiime taxa filter-table.

About rarefaction vs rarefied, it was mentioned in the workshop. I used 15000 as sampling depth because sample with the lower reads counts were 15506. Without filtering out the mitochondria/chloroplast the same sample has 16699.

Once more, thank you for your prompt answer. Thank QiimeForum!

1 Like