Technical problem while installing Qiime2 on windows10 because of Qiime2 certificate

I could not install Qiime2 on my Windows using Anaconda as i got this message:

-2022-08-01 21:18:54--  https://data.qiime2.org/distro/core/qiime2-2022.2-py38-linux-conda.yml
Resolving data.qiime2.org (data.qiime2.org)... 54.200.1.12
Connecting to data.qiime2.org (data.qiime2.org)|54.200.1.12|:443... connected.
ERROR: cannot verify data.qiime2.org's certificate, issued by 'CN=Sectigo RSA Domain Validation Secure Server CA,O=Sectigo Limited,L=Salford,ST=Greater Manchester,C=GB':
  Unable to locally verify the issuer's authority.
To connect to data.qiime2.org insecurely, use `--no-check-certificate'.

Hi @hadeerismail22,

Thanks for reaching out! Before assisting you with this question, I did want to share a friendly reminder with you that cross-posting is against our Code of Conduct on the QIIME 2 Forum, so please make sure to only submit a single post per separate question that you have for us, and don't email any of our moderators directly. This helps us keep things organized on our end. Thanks!

Hi @hadeerismail22,

Circling back on your original question - while I think it should be fine to just enable the --no-check-certificate flag on your end, this may be slightly unrelated (depending on the OS you are attempting to run QIIME 2 on).

If you are using Windows, I'd check out this related forum post regarding the command line utility that we recommend, if you aren't already using WSL.

If this doesn't resolve the issue, and enabling the --no-check-certificate flag doesn't resolve it either, please let us know and we can dig a bit deeper!

Cheers :lizard:

1 Like

Thank you so much for getting me back fast.
I have already tried to run —no-check-certificate, and I got that message: '--no-check-certificate' is not recognized as an internal or external command,
operable program or batch file.

I am using windows subsystem for linux already, and still have the same problem

Hi @hadeerismail22,

Can you re-run your command and copy/paste your full command along with the output from your terminal? Thanks! :lizard:

i ran "--no-check-certificate"
i got this: --no-check-certificate
'--no-check-certificate' is not recognized as an internal or external command, operable program or batch file.

Hi @hadeerismail22,

My apologies for not clarifying - can you please try re-running your original command without including --no-check-certificate and copy/paste the entire command and terminal output in your response? Thank you!

I ran the same command and unfortunately i got the same message

Hi @hadeerismail22,

Can you please provide the following information:

  • What machine you are running these commands on?
  • How you are attempting to install QIIME 2 (virtual machine, direct conda install, etc)?

Thanks! :lizard:

Thank you for getting back to my message,

I am using HP EliteBook 850 G5, Windows 10

I directly installed Conda

Hi @hadeerismail22 ,

Thanks for telling me more! Are you doing this conda install from the Windows CMD or Powershell terminal, or using Windows Subsystem for Linux and the Posix shell? While conda is native on both Windows and Linux, we test and run Qiime2 only on Linux/Posix/WSL and not on native Windows 10.