taxonomy: qiime feature-classifier command

Hello!
I’m I having some difficulty in using the “qiime feature-classifier” command.
I downloaded the gg-13-8-99-515-806-nb-classifier, and wanted to run the commands:
qiime q2-feature-classifier classify-sklearn
–i-classifier gg-13-8-99-515-806-nb-classifier.qza
–i-reads rep-seqs.qza
–o-classification taxonomy.qza
I got the error:
Error: QIIME 2 has no plugin/command named ‘feature-classifier’.
I am using qiime 2019-4
What am I doing wrong?
Please help.

Hi! Try to remove “q2-” before feature-classifier

1 Like

Hi timanix,
Thanks for trying to help. Unfortunately the problem persists…
I get the same error.
Faiga

Hey @Faiga,

Could you run the following commands in your environment:

conda list

and

qiime info

Also maybe provide a screenshot of the command you ran and the error in the terminal? What you’ve provided doesn’t quite line up with what q2cli on QIIME 2 2019.4 will do in the situation you’ve described, so I would just like to confirm.

Thanks!

Hi @ebolyen,
Thanks for your reply.
I ran the commands. The screenshot is as follows:


Any ideas?
Faiga

Hey @Faiga,

It appears that the feature-classifier plugin is not installed based on the tail end of the qiime info I see in your screenshot.

This means that something went wrong when creating the QIIME 2 environment (or sometime afterwards)

I would recommend destroying the environment and reinstalling it. It’s possible that at some point you upgraded scikit-learn, conda would have provided the option of uninstalling feature-classifier to solve the environment specification (thus removing the plugin).

I think starting over with the environment will be the easiest.

1 Like

Hi @ebolyen,
Sorry for the “basic” question but, does this mean I have to delete the qiime2 version installed in my computer and install it again?
Thanks again,
Faiga

No worries, and yes! You can do that with this command:

conda env remove -n qiime2-2019.4

Since we’ve just released a new version (2019.7) you may as well update to that while you are at it :smile:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.