Taxonomy classifier memory error zsh: killed

Hi guys,

I’m having an issue I’m trying to solve for the last 3 days, unsuccessfully (qiime2, v2018.11).
I’m running:

qiime feature-classifier classify-sklearn --i-classifier silva-132-99-515-806-nb-classifier.qza --i-reads combined_rep_seqs.qza --o-classification taxonomy.qza

and after 10 minutes, I’m getting this error:

> zsh: killed qiime feature-classifier classify-sklearn --i-classifier --i-reads

My machine has 35 GB memory and 4 GB of Swap, and it seems that the process drains the memory, and then just killed. Any thoughts? it’s only occurred once, and only with this command.
I also tried to use smaller rep-seqs.qza file (400 KB instead of 1900 KB), but still getting the same error.

Thank you,
Barak

Yeah, you don’t have enough memory to complete this command successfully. If you are unable to move to a machine with more memory, you can try setting --p-pre-dispatch to 1*n_jobs, but that might not help. The problem here is the Silva database - its huge.

1 Like

Hi @thermokarst,

I changed the n-reads-per-batch to 10000 and it worked with the SALIVA!

Thanks,
Barak