Taxa plots shows all samples


#1

Hi,

Even though I filtered my sequences using dada2 and some samples were lost, when I use that table to get my taxa plot, still all the samples are there. How is that possible?


(Matthew Ryan Dillon) #2

What version of QIIME 2 are you running? Can you provide your barplot QZV so that we can see an example of what you are describing (also, we can then look at the provenance)? Thanks! :t_rex: :qiime2:


#3

Hi,

It’s QIIME2/2018.8.


#4

Also, most of my human and marmoset samples taxa are either unidentified or identified at the kingdom level only. I tried training the classifier based on primers and it got even worse.


(Nicholas Bokulich) #5

Thank you for sharing the QZV

The provenance for that barplot indicates that you are using an unfiltered table as input — is it possible you mixed up the files?

It looks like you opened up this topic, so this question will be answered there:


#6

unfiltered? hmm I don’t think so because the table, rep-seq and everything I got is after the filtering step.


(Nicholas Bokulich) #7

I only mean that you did not explicitly remove these samples with qiime feature-table filter-samples. I understand that some samples had all reads filtered out by dada2 — could you please share your dada2 stats results?


#8

You’re right. For some reason, I thought my water samples were removed but they were not removed completely. One of them had only one read left after all the filtering steps. So based on this stats, does it mean that for example, after all the filtering steps, NC2 has still one read left? Should I look at the last number under non-chimeric to see how many reads are left?

v3v5-20181012-stats-dada2-s.qzv (1.2 MB)


(Nicholas Bokulich) #9

That is correct. The filtering steps read from left to right in that visualization, so chimera filtering is the last step and that number will tell you how many reads were retained in each sample after filtering. It looks like only one sample had all reads filtered, and I do not see that sample in the barplot: BRH1480294


#10

Hi Nicholas,

Thanks for your reply. Just another quick related question. When I run beta diversity analysis and get the emperor plots, I have only one marmoset sample left even though the dada2 filtered data does not show that any of the samples are removed. When I want to compare beta-diversity, it tells me that I have two species with only one sample size. How is that possible when dada2 shows except for one human sample, everything else is retained.

bray_curtis_emperor.qzv (774.3 KB)


(Nicholas Bokulich) #11

This is because the “core-metrics” action you are using performs even rarefaction prior to calculating pairwise distances. Looks like you selected a rarefaction depth of 1162: any samples with fewer sequences will be dropped from this analysis.


#12

Oh yes, I just recognized that. Sorry, It’s been a while since I analyzed these and now I’m trying to go back and troubleshoot things and I confused myself. so it makes sense why I don’t have these samples for the diversity analysis but I have them for taxonomy analysis. Considering that I am dealing with low biomass samples (blood), do I need to still have a sampling depth higher than 1000? I made rarefaction plots and for some samples 500 seem to be enough and for some 3500. My samples’ sampling depth are pretty low so even setting it at 1162 ended up removing half of the samples.


(Nicholas Bokulich) #13

Using rarefaction to decide a reasonable rarefaction depth is the right path. Sounds like your diversity estimates may be a bit unreliable if you are undersampling, but it is a compromise you need to make given the low sequence depth you have. A common problem with low-biomass samples!


#14

So you suggest that I still go with at least a 1000?


(Nicholas Bokulich) #15

Sampling depth is always really subjective, and it really depends on your own goals. Less than 1000 sounds very low and would probably not give reasonable diversity estimates.


(system) closed #16

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.