Shotgun distribution: Illegal instruction (core dumped)

Hello.
I installed QIIME2 Shot-gun distribution.
But, there is an error.

Illegal instruction (core dumped)

What is the error called illegal instruction (core dumped)? How can I resolve this error?
I am a graduate student, and I am using the computer infrastructure server provided by my school. Is the error related to using the computer infrastructure server?

Please help me. Thank you!

Hi @sooni,
Can you post the command you ran to install the qiime2 shotgun distro? Also what OS are you on?

Thank you

1 Like

I installed QIIME2 with the following command.

wget https://data.qiime2.org/distro/shotgun/qiime2-shotgun-2023.9-py38-linux-conda.yml
conda env create -n qiime2-shotgun-2023.9 --file qiime2-shotgun-2023.9-py38-linux-conda.yml

And, I use Ubuntu.

Thank you.

1 Like

Hi @sooni,

It seems likely - it certainly couldn't hurt to get in contact with your sysadmin and see if they have any suggestions for this, or if they can assist with the installation.

Have you installed other versions of QIIME 2 successfully on this server, or is this your first attempt?

Previously when I installed it on WSL on my laptop it worked fine. I guess I'll have to ask the server administrator. Thank you!

Hello. I reinstalled QIIME2 shotgun distribution with the following command.

source deactivate
conda env remove -n qiime2-shotgun
conda clean --all
conda update conda
conda install wget
wget 'yml address'
conda env create -n qiime2-shotgun --file 'yml file name'

Then, the same errors occurred in the txt file. How can I solve this problem?
SafetyError.txt (17.2 KB)

Hi @sooni,

Thanks for following up! It looks like you are receiving a different error this time - in the .txt file you provided, the error is showing as follows:

ClobberError: This transaction has incompatible packages due to a shared path.

Looks like there's something funky going on with conda here - did you receive this error when running the conda env create command, or when attempting to activate the environment?

1 Like

'ClobberError' was received me when I run the conda env create command.

When I asked the person in charge of the computer infrastructure server, I found out that qiime2-shotgun could not run because the CPU of the server I was using did not support AVX. Now I've solved the problem! Thank you!